0

I just started learning Linux about a few months ago so apologize if I am missing something easy. I have a Debian 8 server on Google Cloud Platform that I have setup it up to run a Wordpress multisite install. Server works great but I wanted to FTP all data from my current host; Host Gator. I was going to use GoodSync to do FTP to FTP data sync. (Side note, Host Gator have prevent me from creating a server back up due to disk size limitations and CPU resource/php timeout limitations prevent me from using Wordpress plugins to do a migration.)

So I have the FTP working on Host Gator's server but when I try to set up the FTP on my server, I noticed that FTP port 21 is not listening. I already opened up port 21 specifically on GCP via Network - Firewall. I did scanned the ports with a phone app, port 21 used to report back as blocked but now it's closed so I think the network side is fine.

This is what I get when I run this script to see if ProFTPD is running:

ps -ef | grep proftpd
proftpd    570     1  0 Sep25 ?        00:00:01 proftpd: (accepting connections)

I see that ProFTPD is running and listening on port 2222 (tcp6 per netstat) but that doesn't do me any good as GoodSync only allows for port 21 FTP connections.

Finally, I did review the ProFTPD configuration and it's shows port 21 there.

Any help would be greatly appreciated. Thanks.

migrated from serverfault.com Oct 7 '16 at 22:19

This question came from our site for system and network administrators.

  • Could you provide the proftpd.conf (sanitized for sensitive info) that you are using? – Castaglia Sep 29 '16 at 18:01
  • Here is the proftpd.conf: link – Alton Sep 30 '16 at 10:49
  • The config doesn't show any Port 2222 -- although maybe the Include directives are pulling in other files which use Port 2222. Interesting. Can you connect to port 21, from that GCP instance itself, e.g. ftp localhost 21 or ftp localhost 2222? If so, then the issue is probably in the networking setup somewhere; if not, the issue might be with the ProFTPD configuration in some fashion. – Castaglia Sep 30 '16 at 14:51
  • I tried over the weekend connecting to the server internally via port 21 and it didn't work. I think I'll just manually reupload all the files and call it day. – Alton Oct 3 '16 at 19:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy