2

I noticed that my vi editor changes inodes when editing files, except when that file is under /tmp. Why is this?

4
  • 1
    Could you provide an example of what you see, and what you expect to see? – StandardEyre Oct 7 '16 at 16:06
  • Yes, when I edit I file in VI, the inode changes for every time I save the file, but when I am editing a file under the /tmp directory, the inode does not change when editing a file under "/tmp" – chromechris Oct 7 '16 at 16:11
  • the vim options may be in /etc/vimrc – Jeff Schaller Oct 7 '16 at 17:08
  • Thanks guys, I had noticed "unix.stackexchange.com/questions/36467/…", but that did not answer why inodes would remain constant when files were edited under "/tmp". I think this lays in /etc/vimrc, like jeff-schaller mentioned. – chromechris Oct 7 '16 at 17:16

Browse other questions tagged or ask your own question.