2

I'm running OpenSuse Tumbleweed with gnome 3.22.


I need to set my MTU to 1472. If I do so with with:

ip link set mtu 1472 dev ppp0

it works:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
   valid_lft forever preferred_lft forever
inet6 ::1/128 scope host 
   valid_lft forever preferred_lft forever
2: enp1s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether 88:ae:1d:59:7c:1a brd ff:ff:ff:ff:ff:ff
inet6 fe80::2c7:1e3d:2a85:7a43/64 scope link 
   valid_lft forever preferred_lft forever
3: wlp6s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
link/ether 5a:37:1f:84:93:99 brd ff:ff:ff:ff:ff:ff
16: ppp0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1472 qdisc pfifo_fast state UNKNOWN group default qlen 3
link/ppp 
inet 31.176.245.43 peer 109.175.48.1/32 scope global ppp0
   valid_lft forever preferred_lft forever

But as soon as I open the NetworkManager and restart the connection I'm back to 1500...

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
   valid_lft forever preferred_lft forever
inet6 ::1/128 scope host 
   valid_lft forever preferred_lft forever
2: enp1s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether 88:ae:1d:59:7c:1a brd ff:ff:ff:ff:ff:ff
inet6 fe80::2c7:1e3d:2a85:7a43/64 scope link 
   valid_lft forever preferred_lft forever
3: wlp6s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
link/ether 5a:37:1f:84:93:99 brd ff:ff:ff:ff:ff:ff
17: ppp0: <POINTOPOINT,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 3
link/ppp 
inet 92.36.220.222 peer 109.175.48.1/32 scope global ppp0
   valid_lft forever preferred_lft forever

I also tried editing the file /etc/ppp/options to no avail.

Setting the MTU from within the NetworkManager GUI doesn't work either.

1 Answer 1

1

OK, I couldn't find any configuration that works, but it is possible to add a dispatcher script into /etc/NetworkManager/dispatcher.d dir.

Adding something like:

#!/bin/bash

ip link set mtu 1472 dev ppp0

should do the job.

Still, this should be possible with a config file, no?

The config files under /etc/NetworkManager/system-connections don't work. They can be edited from within the GUI too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.