As soon as I start TeamSpeak other applications (e.g. FireFox, VLC Player, ...) gets muted. Additionally, these applications get muted again (after I un-muted them manually) from time to time while TeamSpeak is running.

I know that I had the same problem with older versions of Mumble. I remember some Mumble-dev stating that Mumble once was registered as "phone application", thus the PulseAudio or so mutes other applications while "phone applications" are running.

Newer versions of Mumble do not have this issue, because they are running as "Games" or something like that.

However, like always, the TeamSpeak devs are not helping at all. Hence, I thought maybe I can force PulseAudio to stop this stupid auto-muting.

Does somebody know if PulseAudio can be configured to stop auto-muting applications when "phone applications" are running? Or generally turning off any auto-mute functionality? I want to always control volume/mute myself.


In the superuser community this solution was recommended by the user Sam Watkins.

You can make this automatic on boot by executing (perhaps in /etc/rc.local): /usr/bin/amixer -c 0 sset "Auto-Mute Mode" Disabled

| improve this answer | |
  • Normally, this should solve the problem. In my case it did not :/ If I start alsamixer I have two soundcards PulseAudio and Realtek ALC293. Auto-Mute is disabled for the Realtek Card, but PulseAudio does not offer an Auto-Mute option and alsamixer says that PulseAudio is default -.-" – daniel451 Oct 13 '16 at 11:11

At first I thought that what fixed it for me was setting TeamSpeak to use ALSA in capture and playback options.

However, I actually found the real cause behind this happening. It's pusleaudio plugin called Cork. Apparently it's buggy and it doesn't play well with Qt applications. If you don't want other sources muted when using voice streams in Qt applications you'll have to either comment out or remove the line in the /etc/pulse/default.pa:

load-module module-cork-music-on-phone

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.