2

When upgrading from Jessie to Stretch, at the end of dist-upgrade, it ends with an error:

Errors were encountered while processing:
 nagios-nrpe-server
 E: Sub-process /usr/bin/dpkg returned an error code (1)

Have tried running apt upgrade, install, and reinstall without correcting this.

What to do?

3

To finish installing nagios-nrpe-server, I ended up verifying the post-install scripts.

At nagios-nrpe-server.postinst:

#!/bin/sh
set -e
# Automatically added by dh_installinit
if [ -x "/etc/init.d/nagios-nrpe-server" ]; then
    update-rc.d nagios-nrpe-server defaults >/dev/null
    invoke-rc.d nagios-nrpe-server start || exit $?
fi
# End automatically added section

As I have nagios-nrpe being invoked by (x)inetd and not running as a daemon, it failed startup and thus the apt dist-upgrade error.

For the moment commented out the start line, considering whether filing up a bug, and/or changing from xinetd to a daemon. I use xinetd because I also use it to invoke the backup daemon.

  • 1
    Please file a bug... – Stephen Kitt Oct 7 '16 at 12:58
  • Bug reported with reportbug – Rui F Ribeiro Oct 7 '16 at 15:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.