3

I'm trying to play a MIDI file in my Linux Mint 18 Cinnamon. I just open the MIDI file with any music player and it says it requires a plugin named gstreamer1.0-plugins-bad, so I click "Install" and then nothing happens, the player can't play the MIDI file.

I tried to install the plugin using apt-get install gstreamer1.0-plugins-bad but it says gstreamer1.0-plugins-bad is already the newest version (1.8.2-1ubuntu0.1).

Any music player (including the "Video" application) says it needs this plugin every time I try to play a MIDI file, then just nothing happens.

OS: Linux Mint 18 Cinnamon 64 bit; Cinnamon version: 3.0.7; Kernel version: 4.4.0-38-generic.

Any idea?

Edit: The thing I need is playing a MIDI file using any audio player, I know there's VLC and its own plugin that can play MIDI file on its own, but what I need is playing a MIDI file using for ex. Banshee, Video or a professional audio producing software through a system plugin.

closed as off-topic by Jeff Schaller, Shadur, Rui F Ribeiro, G-Man, Isaac Feb 12 '18 at 3:27

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, Shadur, Rui F Ribeiro, G-Man, Isaac
If this question can be reworded to fit the rules in the help center, please edit the question.

  • See the Arch wiki. – CL. Oct 6 '16 at 11:18
  • As wiki says: "You can play MIDI files on GNOME Videos and all other players using gstreamer as backend after having installed gst-plugins-bad (which provides fluidsynth as a dependency)". Unfortunately, this does not work for me. – Melody Oct 6 '16 at 11:21
  • Other thing I tried: apt-get install gstreamer*, then apt-get install fluidsynth*, still not working. – Melody Oct 6 '16 at 11:26
  • "... and correctly configured Fluidsynth with a sound sample." – CL. Oct 6 '16 at 11:28
  • I followed the wiki to configure Fluidsynth, but I couldn't follow it because I think it's already set in my system. I tired to install freepats but it appears to be already installed. Also I found that Timidity has been installed and it can actually play midi files via terminal. Instead, fluidsynth cannot play any midi files. – Melody Oct 6 '16 at 11:40
0

As far I remember, you need to load the MIDI file (of the right instrument). This file generate the wave file from digital MIDI notation. On older time, this file was proprietary (and with different quality across vendors), and distributed with the hardware. Now there are open files, but you need to select what kind of instrument do you want and play it.

Not the answer you're looking for? Browse other questions tagged or ask your own question.