7

On Arch Linux, I've backed up my system with rsync and restored it again, but it seems that my way of doing it (which I did get from the Arch Wiki but must be wrong?) has kept old files deleted by Pacman. This results in the error duplicated database entry when I try to upgrade my system with pacman -Syu. What should I do?

5

I suggest that you read the information in the links here and here.

Basically, you need to remove the duplicates (manually or using a script) from /var/lib/pacman/local/.

  • Thanks, this seems to have worked. I couldn't get the script to work though, so I had to do it manually. – Toothrot Oct 6 '16 at 11:15
  • This also worked using MSYS/MINGW on Windows. +1 – linux64kb May 16 at 18:27
0

I just went through this. You need to us the rsync --delete option. The Arch wiki is wrong about the --delete option altering anything in the source system. It will only delete files in destination if they have been deleted or are not in source. This will also prevent a bunch of unwanted files building up if you run the backup on a regular basis.

Source1

Source2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.