1

I'm trying to route/bridge/forward (no matter what kind of trickery) all the traffic from wlan0 to eth0. My setup should look like this:

|wireless network| > |wlan0| > |eth0| > |router| > |another wireless network|

So basically eth0 should output something a router can understand. I did my research and so far:

  • bridge-utils does not work
  • Ubuntu's Network Manager does not work (IPv4 "Shared with other computers" mode)

Any help is appreciated!

1

IP forwarding needs to be enabled for this to work. By default it's set to 0, you can turn it on by setting it to 1 with this command.

echo 1 > /proc/sys/net/ipv4/ip_forward

This might be enough by itself, if it isn't, then try configuring the default gateway so that traffic automatically goes out of eth0.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.