0

OS: Linux Slackware 14.2, GUI: KDE. I have a touchpad on my laptop and it bothers me a lot when typing, so I decided to disable it. It can be done with command:

bash$ synclient TouchpadOff=1

To do it on startup I created a script my_startup.sh:

#!/bin/sh

synclient TouchpadOff=1

And put it into the folder ~/.kde/share/autostart. Made executable. When I open "System Settings" --- "Startup and Shutdown" --- "Autostart" it shows the script as enabled:

enter image description here

But it doesn't work - the toupad is enabled and I have to run the script manually every time.

What's wrong?

  • It might not be finding synclient if PATH isn't set at that point -- have you tried giving the complete path (which synclient)? – Ulrich Schwarz Oct 5 '16 at 11:21
  • Try synclient TouchpadOff=1 &>/tmp/login.log to see if it does really run on login or if there are errors. BTW AFAIR I saw an option in kde config GUI to auto-disable touchpad if a mouse is plugged in, which I found useful. – rudimeier Oct 5 '16 at 11:31
  • @UlrichSchwarz Seems to all right: bash-4.3# which synclient --> /usr/bin/synclient – user4035 Oct 5 '16 at 11:31
  • @rudimeier Did it, will try on the next startup. How to find this option? – user4035 Oct 5 '16 at 11:32
  • Maybe linux-apps.com/content/show.php/kcm_touchpad?content=113335, Could be that such module is included by default in KDE > 5.3: bugs.kde.org/show_bug.cgi?id=189567 – rudimeier Oct 5 '16 at 11:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.