1

hello I have been installed libfuse and sshfs in my ubuntu and the kernel version is 4.4.0-38.

And now I want to sshfs user@localhost:/dir /mnt. but it always shows the error message:

read: Connection reset by peer

How come it always happened? Is there anyway to mount a disk by fuse?

  • You're missing the port. – Julie Pelletier Oct 5 '16 at 5:34
  • @JuliePelletier I tried, still not. eg. sshfs -o port=1234 user@localhost:/home /mnt – yayaya Oct 5 '16 at 6:22
  • What does the pure ssh reports? ssh -vvv user@localhost? Did you set up the access? – Jakuje Oct 5 '16 at 8:38
  • @Jakuje sorry, how to set up the access? thanks – yayaya Oct 5 '16 at 8:45
  • 1
    @Jakuje Oh, I knew. I didn't install the openssh-server on ubuntu, it closed default. Thanks – yayaya Oct 5 '16 at 8:58
1

Running the pure ssh in debug mode (ssh -vvv user@localhost) will give you a guide what is wrong. In this case, you need to install the openssh-server package to have where to connect.

  • BTW, Is there anyway to mount 2 filesystems by FUSE? thx – yayaya Oct 5 '16 at 10:08
  • Yes, but you need to choose different mount point. – Jakuje Oct 5 '16 at 10:35
  • any words about that? – yayaya Oct 5 '16 at 10:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.