2

Up until kernel 4.6 I was able to mount ecryptfs mounts which had top-level directory plain but lower directories encrypted.

From kernel 4.7 onwards I cannot do that anymore.

Encrypted home is at /.private/backup and mount point is at /mountpoint.

Mounting is done from .private not from .private/backup as shown below:

$> mount -t ecryptfs /.private /mountpoint

$> ls /mountpoint/backup

ls: cannot access /mountpoint/backup: No such file or directory

?????????? ? ? ? ? ? backup

If I mount

$> mount -t ecryptfs /.private/backup /mountpoint

then everything is OK.

I am using the following options rw,noauto,user,no_sig_cache,ecryptfs_passthrough=n,ecryptfs_sig=xxxxxx,ecryptfs_cipher=blowfish,ecryptfs_key_bytes=56,ecryptfs_fnek_sig=xxxxxxx,ecryptfs_unlink_sigs,key=passphrase:passphrase_passwd_file=/root/.ecryptfs/passwd.txt

Using ecryptfs_passthrough=y did not seem to make any difference.

What could be the reason?

2

The ability to look up plaintext and encrypted filenames, under the same eCryptfs mount point, has been disabled with the following commit in 4.7:

https://git.kernel.org/linus/88ae4ab9802eaa8e400e611f85883143d89d6b61

Supporting both forms of filenames in the lower filesystem has proved to be problematic and it was decided that only one or the other should be usable under a given eCryptfs mount point. I'm sorry to hear that your use case was affected by the decision but I don't think that use case can be supported at this time.

  • OK. Thanks. Nice to know that. Have been googling around but could not find the answer. – Octavian Oct 4 '16 at 18:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.