0

I've been tweaking my conky config and getting the error

conky: llua_do_call: function conky_cpu execution failed: attempt to call a nil value

The function conky_cpu resides in ~/.conky_cpu.lua. That feels strange to me because conky works fine when the .conky_part.lua is not loaded. Moreover, the same error happens even when the .conky_part.lua is empty.

lua_load = '~/.conky_cpu.lua',
lua_load = '~/.conky_part.lua',
  • You could add a print(conky_cpu) at various parts of the lua code to see if it gets changed at all. – meuh Oct 4 '16 at 16:02
  • @meuh you mean some kind of cache there? I've never seen that before when loading an empty files gives you errors. – sitilge Oct 4 '16 at 19:37
  • Without any code, or configuration you changed, it is very hard to help you. – Jakuje Oct 10 '16 at 17:32
1

I had similar problems trying to load multiple Lua files, finally stumbling onto the following, which worked:

lua_load = '~/.conky_cpu.lua ~/.conky_part.lua',

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.