2

I am working on RHEL 7.2 and I want to install LibXp.so.6 and LibXmu.so.6, but I have problem with glibc-common-2.17-105.el7.x86_64.rpm and glibc-2.17-105.el7.i686.rpm because they need each other.

[root@hostname ~]# rpm -i glibc-2.17-105.el7.i686.rpm
warning: glibc-2.17-105.el7.i686.rpm: Header V3 RSA/SHA256 Signature, key  ID f4a80eb5: NOKEY
error: Failed dependencies:
        glibc-common = 2.17-105.el7 is needed by glibc-2.17-105.el7.i686
        libfreebl3.so is needed by glibc-2.17-105.el7.i686
        libfreebl3.so(NSSRAWHASH_3.12.3) is needed by glibc-2.17-105.el7.i686
[root@hostname ~]# rpm -i glibc-common-2.17-105.el7.x86_64.rpm
warning: glibc-common-2.17-105.el7.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID f4a80eb5: NOKEY
error: Failed dependencies:
    glibc = 2.17-105.el7 is needed by glibc-common-2.17-105.el7.x86_64

How should I install this? I don't have connection to the internet so I can't use yum, only rpm.

What's more, I think these libraries are installed:

[root@hostname ~]# rpm -qa | grep glibc
glibc-common-2.17-105.0.1.el7.x86_64
glibc-2.17-105.0.1.el7.x86_64
  • Try installing them both together, i.e. rpm -i glibc-2.17-105.el7.i686.rpm glibc-common-2.17-105.el7.x86_64.rpm – Flup Oct 4 '16 at 8:12
  • ok, i know it is stupid but i didnt realize its possible to install few rpm's at once... thanks, it works! Now i have a couple conflicts cause i have istalled a newer lib but i will solve it by my own. – new_in_rhel Oct 4 '16 at 8:39
  • Not at all -- we all have to start somewhere! I'll add this as an answer. – Flup Oct 4 '16 at 8:40
3

Where packages are co-dependent you need to install them together like this:

# rpm -i glibc-2.17-105.el7.i686.rpm glibc-common-2.17-105.el7.x86_64.rpm 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.