2

lock screen session suspension in debian jessie

I just read of an issue that seemed similar to mine, and as I cannot comment yet and my problem is different I will ask my question outright. the similar issue can be found here: Suspend does not work on Debian Jessie

My 'particular' issue is that I seem to not only be unable to suspend but lock the screen or hibernate as I did in Wheezy. I find it odd that such a basic function doesn't work in a 'stable' release. Namely I use the lock screen frequently. When I couldn't, for the first time, I didn't. My system was unresponsive when I came back 30 minutes later. I ended up for restarting. On the upside, I am aware the 'much' of what was in the state it was can be directly recovered due to journaling.

Even so, there are things that are immediately obvious as not being how they were when I left. Frankly, I'm grateful that it's not more severe!

Still does anyone know the 'proper' way to report this bug? Also since my upgrade I don't yet have the anti-bug / bug tracking packages installed as of now. (My OWN fault, I know. If I did, I would be sending bug / craaash reports as I did in 'Wheezy'.)

also may be significant: KDE version changed to 4.14.2 (from 4.7.x I believe.) Dolphin also @ 4.14.2

I saw something similar here: How to hibernate in Debian Jessie but I really have no idea IF it aookies ti what I am working with. Thx in advance!

  • You didn't post the link to Suspend does not work on Debian Jessie. – Tomasz Oct 4 '16 at 8:09
  • hmmm. I never thought to use such a LOOONG tag :O. Clearly I am new, but that is QUITE descriptive :D. Thank you! – Tim Danielson Oct 4 '16 at 18:13
  • I tried. I do not have the rep to create new tags which is apparently what I must do. :( – Tim Danielson Oct 4 '16 at 18:21
  • No, to post a link highlight the text it should be covered by, press the link button and then paste the link. I mean the last sentence of the first paragraph. – Tomasz Oct 4 '16 at 18:35
  • OK, hope this edit will be what you are looking for? – Tim Danielson Oct 8 '16 at 20:11
0

You can try the pm-utils package for a bunch of power management commands. These are:

pm-hibernate       pm-powersave       pm-suspend-hybrid  
pm-is-supported    pm-suspend  

As for the lock, there's the package xscreensaver in the repository. You might give it a try.

  • Honestly, I haven't played with the command line much. BUT, as I KNOW it is a hole in my knowledge, I will what you suggest a try :D – Tim Danielson Oct 4 '16 at 18:16
  • on pm-utils & pm-is-supported I am being told the command is not found by konsole. – Tim Danielson Oct 4 '16 at 18:24
  • You need to install the pm-utils package. Type this on the command line: sudo apt-get install pm-utils. And now press enter. – Tomasz Oct 4 '16 at 18:37
  • OK. Job done. Sorry I kind of gave up on it for a few days. Fortunately THIS is a home PC and not a work one. If this was @ work, this would be totally unacceptable. I WOULD have to log out and back on each time. I can't imagine running a server in this fashion! – Tim Danielson Oct 8 '16 at 20:27
  • OK, tried pm-suspend and have it working. I have no idea about xscreensaver though. – Tim Danielson Oct 8 '16 at 20:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.