1

Im running Mint 18 and I want to install SSTP + network manager extension (http://sstp-client.sourceforge.net).

The problem Im running in to is that network mgr extension depends on "ppp version 2.4.6" AND Mint 18 uses "ppp version 2.4.7", which has libraries and software which depends on v. 2.4.7 - as you can see, I would be breaking dependencies (Yep,Ive tried).

Is there any way to solve this issue?? Any help will be greatly appreciated.

2

According to the upstream configure.ac, version 2.4.7 of ppp should be supported — in fact that's the default version if no plugin directory is specified when configuring.

However, instead of compiling the extension yourself, the simplest solution is probably to use the binaries available in the corresponding PPA; just follow the instructions for Debian and Ubuntu, which should also work with Mint:

Debian/Ubuntu users can now use my personal PPA to download and install the network-manager-sstp and sstp-client project via launchpad.

You can import the gpg key using the following command:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 61FF9694161CE595 

Put the following two lines into the following file: /etc/apt/sources.list.d/sstp-client.list

deb http://ppa.launchpad.net/eivnaes/network-manager-sstp/ubuntu xenial main
deb-src http://ppa.launchpad.net/eivnaes/network-manager-sstp/ubuntu xenial main

Then use your apt-get command to get both network-manager-sstp and sstp-client.

  • Great! Thank you very much! Packages are now installed, but I still cant see SSTP in network manager. Ive installed: libsstp-client, sstp-client, network-manager-sstp, network-manager-sstp-gnome - but still no sign of SSTP anywhere - only PPTP and Open VPN. Is it hidden somewhere in PPTP settings ? Network manager version installed: 1.2.2-0ubuntu0.16.04.1 – RiddleMeThis Oct 5 '16 at 8:26
  • I see it by opening the system settings, going into "Network", clicking the "+" button in the bottom-left-hand corner, and selecting VPN; then it appears alongside the other supported VPNs on my system (Cisco, OpenVPN, PPTP, and SSTP). – Stephen Kitt Oct 5 '16 at 8:36
  • Yep, I tough it would be like that. SSTP is nowhere to be seen. What version of NM do you have? In this version I even have problem switching between different OpenVPN servers (I have to restart network manager every time I want to switch). – RiddleMeThis Oct 5 '16 at 8:38
  • I'm running NM 1.2.4 on Fedora 24, with the 1.2.0 SSTP plugin and the 1.0.10 SSTP client. It's odd that you need to restart NM to switch VPNs (or VPN servers), I've never had to do that... – Stephen Kitt Oct 5 '16 at 8:49
  • Im going to switch to fedora (precisely korora - not really big deal for me), It will be faster in my case, than compiling sources of newer NM etc. - also more reliable. I'll let you know. – RiddleMeThis Oct 5 '16 at 12:20
0

It apparently works with linux mint 18.x, just make sure to also install network-manager-gnome-sstp and reboot afterwards.

  • How does it work if there is a dependency mismatch? Can you please provide more detail. – roaima Feb 6 '18 at 16:10
  • I followed the instructions here. Looks like it's the same as @stephen-kitt wrote. No problems with it. sudo apt-get update && sudo apt-get install network-manager-sstp sstp-client installed just fine. Then rebooted and was disappointed, because sstp was not an option then. Then I ran sudo apt-get install network-manager-sstp-gnome and rebooted and there it was: the option "Secure Socket Tunneling Protocol". I'm running linux 18.3 sylvia with cinnamon. – Thomas Praxl Feb 6 '18 at 20:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.