5

I'm on Ubuntu 14.04, and using it through ssh, which means I don't have local GUI for it.

I need to run some command that requires GLX, but things aren't going well.

Xvfb :80 -screen 0 1400x900x24 -ac +extension GLX +render -noreset

If I execute the above, it says Initializing built-in extension GLX. And using vglrun(VirtualGL) targeting that(:80) as a 3D X server, I can see xdpyinfo says that GLX is there, although actually trying to use GLX ends with an error maybe because it cannot be a real 3D X server?

But if I do the following, there is no GLX (and of course GLX doesn't work when I replace xdpyinfo with my command):

xvfb-run -a -n 55 -s "-screen 0 1400x900x24 -ac +extension GLX +render -noreset" xdpyinfo

Am I understanding them in a wrong way?

Could someone please help me? I really need to use xvfb-run...

Thanks!!

UPDATE: I tried -e option for xvfb-run, and confirmed that it also prints Initializing built-in extension GLX. But it still doesn't work.

1

Maybe your Ubuntu installation misses some OpenGL/GLX packages to be able to use GLX. You can try to install mesa-utils (OpenGL in the dependencies) and run glxgears and glxinfo to test it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.