0

(I just had here about 5 paragraphs of text, but all seems worthless, you don't need that much data).

I'm using Kubuntu in BIOS Legacy State as this was the only way I could see USB option in Boot Menu (F12). And it was the only way I could install Kubuntu from USB, from boot. I "burned" USB using OEM Windows 10 and told Kubuntu to take entire disk (effectively wiping out all bloatware).

If I enable BIOS UEFI mode, I see "No Bootable Device" icon because Linux and UEFI don't like one another(?), and already mentioned, list of bootable devices disappear (In Legacy Mode, there are 5 positions, HDD, USB, network etc., in UEFI mode, nothing, empty list).

I ran: dd bs=4M if=/path/to/win10.iso of=/dev/sdx && sync
with correct path and correct USB and it didn't work. Screen flickered couple times and the only thing I saw was Kubuntu's logo and it booting up. WinUSB is not a choice since it's seemingly offline, unetBootin never worked. I'm not aware of any such easy tools

I don't know what to do, is it possible to install Windows 10 on Legacy BIOS from USB on Linux?

Any ideas? How can I successfully "burn" USB, boot it and actually install it?

Currently my computer is in Legacy BIOS mode.

Before DD'ing I set USB to gpt ntfs all formatted. But now it is all:

http://oi63.tinypic.com/351s8x2.jpg

0

This is more of a Windows question than a Linux question. Search for "How to create a bootable USB drive for Windows 10" on the net.

  • Oh, I did try that. It only turns up how to do it on Windows, with Windows program. If I were on Windows this wouldn't be a problem and I would know how to solve such issue, but I don't have any experience with Linux. That's the fall. – As A Guest Oct 2 '16 at 17:57
  • Also, I don't see how it's Windows question, the content of USB doesn't really matter. What matters is the motherboards capability of running it, and Linux's capability of burning it. Windows errors would shine in blue, I don't even get there. It fails before Windows is "launched". – As A Guest Oct 2 '16 at 18:06
  • Ok, fair enough. Most of the guides I have seen on the net describing how to create a bootable Windows USB stick tell you to format it with the FAT32 file system. Some guides tell you to use NTFS, one discorauged the use of NTFS. You will probably need to erase the stick, and make a FAT32 file system on it. Then you'll need to extract the files from the iso (e.g. using a loop mount) and copy the files to the FAT32 file system on the USB stick. – Johan Myréen Oct 2 '16 at 18:24
0

1) From what you wrote, it sounds like you want to not use UEFI and boot Windows 10 in BIOS mode. If so, you probably should not be creating a GPT partition table on your disk. Rod Brooks' excellent EFI site provides some details. Traditionally, MBR is used with BIOSed and this can lead to better compatibility. While in theory it should work this can lead to issues. Here is the problem: when you use dd, it gets the disklabel/ from your image, which is GPT. It seems like your version of GParted cannot deal with GPT either.

If you disable Secure Boot, you should be able to install Windows first, and then boot Kubuntu in UEFI mode.

If you don't want to switch to UEFI boot, try running Windows in VirtualBox.

  • I can't install Kubuntu in UEFI mode because there's no USB to select from boot. I can't run Windows 10 in virtual box because I need DirectX 3D support, which neither VMware nor VirtualBox have. – As A Guest Oct 2 '16 at 17:55
  • @AsAGuest is Secure Boot on? – aidanh010 Oct 2 '16 at 17:56
  • Yep. Whenever I have UEFI or Legacy enabled, in both cases Secure Boot is enabled, but it's grayed out and unchangable. – As A Guest Oct 2 '16 at 18:03
  • @AsAGuest whoa.. unchangable is bad. Is this a new Lenovo laptop or something? Normally MS requires that OEMs allow that to be disabled. What computer is it? – aidanh010 Oct 2 '16 at 18:15
  • Acer Aspire E5-743G, Insyde Rev. 5.0 is all I can provide you with when it comes to dependant hardware. I don't think CPU, GPU and RAM have anything to influence here. – As A Guest Oct 2 '16 at 18:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.