4

Update - I'm on Fedora 25 now but the issue is still unsolved.

I have Fedora 25 Workstation on my laptop. The internet access is through proxy server only.

I have successfully configured proxy settings for dnf and wget. I can install and updates packages using dnf from terminal. wget and firefox also work.

But Gnome Software Center and curl do not work. Everytime I try to install something from software center, I get the error

Curl error (7): Couldn't connect to server for https://mirrors.fedoraproject.org/metalink?repo=fedora-24&arch=x86_64 [Failed to connect to mirrors.fedoraproject.org port 443: Connection refused]

What I have tried so far:

1 : Set proxy settings using dconf-editor (Source)

2 : Manually add proxy info to /etc/PackageKit/PackageKit.conf (Source1) (Source2)

3 : Add proxy info to ~/.bash_profile, ~/.curlrc, /etc/profile (Source)

None of these have worked.

How do I get Gnome Software Center working?

1

You could try working around this by adding proxy=... after every single metalink= line in /etc/yum.repos.d/*.repo. I haven't tested this, but these are only config files which the PackageKit daemon will accept proxy settings from. Support for setting a proxy in /etc/PackageKit has been removed.

What's supposed to happen, is the PackageKit client sets a proxy. With pkcon (console command) this is based on environment variables; with GNOME Software, it is based on the GNOME proxy setting. I think neither of these work correctly at the moment though:

https://bugzilla.redhat.com/show_bug.cgi?id=1348843

In a corporate environment, with proxy only web access, I configure through the GUI the HTTP, HTTPS and FTP proxy.

When I use "Software", nothing happens. I can browse the catalog, but install does not work.

If I use "pkcon" from command-line, I get an error:

[…@… ~]$ LC_ALL=C pkcon -v update
10:04:32  PackageKit          Verbose debugging enabled (on console 1)
10:04:32  PackageKit          failed to set proxy: GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._pk_2dengine_2derror_2dquark.Code3: setting the proxy failed
Command failed: The proxy could not be set: GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._pk_2dengine_2derror_2dquark.Code3: setting the proxy failed

"dnf" works, and the environment is correctly set.

If I unset in the shell all proxy, pkcon tries to download, but fails, obviously.

Version-Release number of selected component (if applicable): I'm using latest PackageKit on F24 : 1.1.1-3.fc24

...

Just updated to F25 final, still the same bug.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.