6

It seems like the notification bar on the bottom of the desktop in Linux Mint 12 never hides unless I click N+1 times on it first (N being the number of messages). Since it's overlaid over all windows (even fullscreen video) it's a bit annoying. Right- and left-clicking the notification bar does not bring up any settings dialog, so I'm wondering how to either automatically hide messages after a timeout, disable the display of certain messages (I don't need to know about external disks which are plugged in at boot time), or (if all else fails) disable the notification bar altogether.

  • I'm also annoyed by this and have found no solution so far :(. Wifi disconnect messages pop up and then must be clicked to go away. – MGwynne Mar 31 '12 at 18:19
3

On Arch Linux I removed exec permission on notification-daemon lib. I found this temporary quick fix when I was searching for solution to this same problem.

$ sudo chmod -x /usr/lib/notification-daemon-1.0/notification-daemon

Some of annoying notifications you can disable here:

$ gnome-session-properties

For example you can disable "Print Queue applet" and you wont get notification about every printed document. Or "Disk Notifications" and this should resolve your "Your USB disk is plugged in" notification problem.

  • The only things shown in gnome-session-properties are "Caribou - No description", "GNOME Login Sound", "mintUpdate", "mintUpload" and "mintWelcome". – l0b0 Feb 10 '12 at 20:23
2

I've decided to turn them completely off: in advanced settings, shell extensions, disable notifications extension

  • 1
    It still shows notifications after disabling notifications, even after logging in again. – l0b0 Mar 2 '12 at 20:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.