1

I am learning about Dockerfile and had not worked with curl before.

When running this Dockerfile . The terminal output gives:

enter image description here

And then:

enter image description here Googleing around tells me that there was an interactive dialog which could not be handled.

The last command I saw in the terminal output was
Step 7 : RUN apt-get install curl -y && ... which starts on line 15 to line 39

How am I suppose to deal with this? Thanks

edit
One of the answers in the link in the comments give a pointer to ubuntu man page, after reading the man page, I am not sure how to incorporate this solution in my case. Any help? thx

edit 2
The accepted answer suggests to use ARG DEBIAN_FRONTEND=noninteractive. How do I incorporate this in my Dcokerfile? thx

  • 2
    please copy the text and post it here as text instead of screenshots – lesmana Oct 1 '16 at 19:33
  • does this help you? stackoverflow.com/questions/22466255/… – lesmana Oct 1 '16 at 19:34
  • @lesmana I tried to copy the text but it will be not formatted and lose end of line, looks bad and difficult to read. – Fred J. Oct 1 '16 at 20:45
  • 1
    SE has a formatting markup, do read that, do read the man page, and understand that telling someone off for giving you RTFM will only produce more people telling you to RTFM. Do RTFM – grochmal Oct 1 '16 at 21:09
1

You have three options:

  1. ignore the messages as they seem to be non-fatal.

  2. replace every RUN apt-get install ... with RUN DEBIAN_FRONTEND=noninteractive apt-get install ...

  3. add ARG DEBIAN_FRONTEND=noninteractive after the FROM ... line at the top.

Using option 3 the first few lines of you linked dockerfile should look like this:

FROM ubuntu:14.04
ARG DEBIAN_FRONTEND=noninteractive
MAINTAINER Stephen Pope, spope@projectricochet.com

read more about ARG: https://docs.docker.com/engine/reference/builder/#/arg

source: https://stackoverflow.com/questions/22466255/is-it-possibe-to-answer-dialog-questions-when-installing-under-docker

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.