1

I just installed Elementary OS and almost everything is working great. The only problem is that the touchpad isn't working. I can not move the cursor with the touchpad. But if I use a mouse it is working fine.

Results when I run xinput:

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Mitsumi Electric Apple Optical USB Mouse  id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ USB2.0 HD UVC WebCam                      id=10   [slave  keyboard (3)]
    ↳ Asus WMI hotkeys                          id=12   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=13   [slave  keyboard (3)]

Please note the Apple Optical Mouse is a usb connected mouse. The touchpad vendor is Elan.

0

A bit of googling found this:

https://askubuntu.com/questions/763584/elantech-touchpad-not-working-on-ubuntu-16-04-and-arch-linux

Specifically:

had the same problem. After googling a lot I found a workaround: in /etc/defaut/grub

sudo nano /etc/default/grub I added i8042.reset to the line GRUB_CMDLINE_LINUX_DEFAULT

GRUB_CMDLINE_LINUX_DEFAULT="i8042.reset quiet splash" and then

sudo update-grub Finally after a restart the touchpad works fine (multitouch included).

Check that out, it may help you :)

  • Thanks a lot for your answer, but the problem is a bit different because when I run xinput I don't see the touchpad. I tried adding the line but it did not do something :( – Gewoo Sep 30 '16 at 13:19
0

I had the similar issue when I updated my OS. It was fixed when I simply rebooted my machine. Please update your OS and reboot your machine and check your xinput list.

  • 1
    You will be surprised to see your touch pad added in the xinput list. – Prabhu Sep 28 '18 at 14:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.