2

Okay, I am out of ideas. There was a power failure during an upgrade, and now the system boots to the terminal, tty1, and the GUI does not load automatically. I have lightdm as my login manager. I can login and use startx to make Cinnamon load, but networking is still shot. I can not get lightdm to run for my life. I have tried dpkg-reconfigure on lightdm, xserver-xorg, and a bunch of other packages. Reinstalling Cinnamon doesn't help. And no, I do not have a NVidia card, so it's not a driver issue. I've also tried setting HEED_DEFAULT_DISPLAY_MANAGER to false. Any help would be appreciated.

System:

HP Pavilion g4 Laptop

amd64 Linux Mint 18

Dual-core AMD Turion II

ATI Radeon Graphics Card

Dual-boot with Chromixium 16.04 i386

0

Have you an older Kernel on your System? Boot it if posible. Try sudo apt -f install If this works without errors.

sudo apt update && sudo apt dist-upgrade
  • No. It is Mint 18 Sarah with fairly up to date packages. – GeoffreyS Sep 30 '16 at 14:07
  • Can you boot in recovery-mode? Have you Network then? Do you have closed-source driver installt? like nvidia? If yes investigate with dkms status the drivers are installt in the new Kernel. 'dpkg -l | egrep -v '^ii|^rc' ' – user192526 Sep 30 '16 at 15:08
  • Yeah, recovery can boot. I can get network if I install lxdm, set it as my login manager using dpkg-reconfigure, and do resume normal boot and plug into ethernet. However, the bigger problem is I can't seem to get mdm, lightdm, or gdm to work. I can only get lxdm to work. startx does work though. Edit: I can use nmcli d connect wlo2 to connect to WiFi, but it just enables a hotspot. Deleting the hotspot now makes the command seg fault. – GeoffreyS Sep 30 '16 at 18:45
  • Please post nmcli d and nmcli c dpkg -l | egrep -v '^rc|^ii' show Packages that are not fully instalt.Try sudo dpkg --configure -a and show ls -al /usr/share/xsessions/ Sorry I overread that you have no nvidia card. I'm fighting here with english and the syntax – user192526 Oct 1 '16 at 9:33
  • Life just got wierder. Wifi works fine with my USB wifi adapter, but not with the built-in one. Anyway, here's what you asked for: StackExchange1 - Pastebin. I poke around some more. – GeoffreyS Oct 1 '16 at 17:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.