6

On fedora 16 I've installed yakuake, and when I hit F12 ( default keybind ) the terminal retracts, but on hitting F12 again it won't deploy down. Does anyone have a thought as to why F12 isn't being processed properly?

One weird effect that I've seen is that when I hit F12 with a konsole open a tilde is generated on the command line. I've looked at the keybindings for kde & for konsole and nothing is bound to F12.

migrated from serverfault.com Feb 9 '12 at 14:46

This question came from our site for system and network administrators.

  • I'm going to rebuild from source and see if that fixes the issue. – Andrew Scrivner Feb 9 '12 at 6:24
  • KDE4 on Fedora16 -- cmake 2.8.7 is buggy and yakuake cannot be built at the moment. – user15353 Feb 9 '12 at 15:43
3

I just had this problem now, and I had a bunch of shells still running that I didn't want to lose. Here's what I did; you can probably find a cleaner way:

  • Run /usr/bin/qdbusviewer (ships with qt-x11)
  • Scroll down to org.kde.yakuake on the left hand side of the "Session Bus" tab, click it
  • On the right side, navigate to:
    • yakuake/
      • MainWindow_1/
        • com.trolltech.Qt.QWidget
          • Scroll down to "Method: show" and double-click it.

Yay! Doing this made yakuake regain its sanity (i.e. F12 works once again).

3

I tried the above answer on Ubuntu 12.04, but it didn't work.

In the end, I disabled the open/retract keyboard shortcut from within yakuake, then I set a global keyboard shortcut from Unity->Keyboard, that just executes "yakuake". Fortunately, the authors of yakuake put a listener in place so only a single instance of it can run at a time. When it detects another instance attempting to open, it just triggers the retract/drop-down function. Bravo!

2

for everyone who still experience same problem this is the fix.

in System->keyboard->shortcuts->custom shortcuts make new .

Name: yakuake Command: qdbus org.kde.yakuake /yakuake/window toggleWindowState

save -> then bind your shortcut and you are done. Tested and working in fedora 22

  • I ended up with the same solution in my Ubuntu 16.04. After upgrade from 14.04 my yakuake stopped functioning properly, more precisely refused to open after successfully retracting by pressing a previously bound from yakuake configuration menu key. Building from source or deleting kde related to yakuake user's configuration files didn't help as well. – 0xC0DEGURU Nov 6 '16 at 11:23
  • When using this method, the yakuake window is not gaining focus, after being shown. The focus stays on the window that had it before pressing the shortcut. – Cray Aug 10 '18 at 12:43
0

I fixed this by disabling the shortcut in Yakuake itself ("none"), then going to KDE Control Panel, Global Keyboard Shortcuts, find Yakuake from the dropdown list of apps, and set open/retract as desired.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy