0

I am using Arch Linux with xmonad Window Manager. I have installed alsa-utils and As per my knowledge , alsa drivers should installed by default.

But when I try open any media file with cvlc, I get this error :

┌─(severus)──(~) 
└─> $ cvlc /run/media/severus/Entertainment/Barton\ Springs\ -\ Bird\ Creek-qIKD169VDy0.opus 
VLC media player 2.2.4 Weatherwax (revision 2.2.3-37-g888b7e89)
[0000000001624e78] pulse audio output error: PulseAudio server connection failure: Connection refused
[000000000166cf38] dummy interface: using the dummy interface module...
ALSA lib pcm_dmix.c:1041:(snd_pcm_dmix_open) unable to open slave
[0000000001624e78] alsa audio output error: cannot open ALSA device "default": No such file or directory
[0000000001624e78] core audio output error: Audio output failed
[0000000001624e78] core audio output error: The audio device "default" could not be used:
No such file or directory.
[0000000001624e78] core audio output error: module not functional
[00007f3318c0ebe8] core decoder error: failed to create audio output
[00007f3318c0ebe8] opus decoder error: Oops: No new buffer was returned!
^C
┌─(severus)──(~) 
└─> $ 

Output of alsamixer :

enter image description here

enter image description here

Output of lspci -k| grep -A 3 -i audio:

┌─(severus)──(~) 
└─> $ lspci -k|  grep -A 3 -i audio
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
    Subsystem: Hewlett-Packard Company Device 2212
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel
--
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
    Subsystem: Hewlett-Packard Company Device 2212
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel
┌─(severus)──(~) 
└─> $ 

Please help me resolve this issue.

1

The problem was , Out put was directed to wrong device (HDMI),

I detected this by doing :

speaker-test -D default:PCH -c 8

So I created a file /etc/modprobe.d/alsa-base.conf

with the following contents

options snd_hda_codec_realtek=0
options snd_hda_intel index=1

Everything works like charm :D

More information : https://wiki.archlinux.org/index.php/Advanced_Linux_Sound_Architecture#Set_the_default_sound_card

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.