1

Since a few days ago I cannot forward X11 anymore on my machine from an ssh server and I can’t figure why.

I work on OSX 10.12 and ArchLinux as a guest virtual machine (VirtualBox hypervisor): when I try to log in the server with the -X flag I get

Warning: No xauth data; using fake authentication data for X11 forwarding.

on OSX (same warning with -Y flag) and no warnings on Arch. Then whenever I try to execute GUI programs I get seg fault on both.

I tried to log in with another machine and everything worked fine, so I must assume there's something wrong with my machine, since I find the same problem with two different OS (can't figure how this is possible). Could be the new OSX 10.12, installed few days ago, the source of this trouble? Any other hint?

My ~/.ssh/config:

    Host *
      ForwardAgent      yes
      ForwardX11        yes
      ForwardX11Trusted yes

I also regenerated the ~/.Xauthority file, but nothing changed.

  • does xauth list $DISPLAY on your osx show an MIT magic cookie? – meuh Sep 27 '16 at 17:25
  • nope, it returns zero output... – Luigi Pertoldi Sep 28 '16 at 21:18
  • I dont have a mac to help further. You might try this question on stackexchange which is similar, the xquartz faq, or posting on our sister site apple.stackexchange.com – meuh Sep 29 '16 at 7:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.