1

This is an yet another question about setting higher resolution in text mode, but I've already tested some solutions posted on U&L and unfortunatelly with no effect.

Let's start at the very beginning: I've fresh (up to date) copy of Fedora 24 with Nvidia proprietary drivers installed and WQHD monitor (resolution 2560 x 1440):

uname - r
4.7.4-200.fc24.x86_64

nvidia-settings --version
370.28

In the past, with lower monitor resolution (1280 x 1024) and nouveau drivers I simply added vga=795 parameter and it was working properly.

Now I have resolution exceeding max VGA (1600x1200) and Nvidia drivers, thus this could cause problems with Kernel Mode-Setting.

In GRUB2 console, I've check the code of desirable resolution:

set pager=1
insmod vbe
vbeinfo

2560x1440 x32  ->  0x14d
2560x1440 x16  ->  0x14c
2560x1440  x8  ->  0x14b

Because, 0x14d (hex) is 333 (dec) I've naively tried to pass vga=333 and video=333. Of course, this approach misfired.

I have also tried to add the following two lines to the /etc/default/grub file:

GRUB_GFXMODE=2560x1440x32
GRUB_GFXPAYLOAD_LINUX=2560x1440x32  

After GRUB2 update grub2-mkconfig -o /boot/grub2/grub.cfg every menuentry was supplied with line set gfxpayload=2560x1440x32 and the load_video function loads VBE:

function load_video {
  if [ x$feature_all_video_module = xy ]; then
    insmod all_video
  else
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
  fi
}

After that I cannot even see anything in text mode, pressing Ctrl+Alt+F3 it shows completly black terminal without any promt, completly nothing.

The last thing I've tried, was installing FBSET, but I get the following error:

open /dev/fb0: No such file or directory

Could I have 2560x1440 in text mode with Nvidia drivers (needed for CUDA dev)?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.