2

I have a WeeChat version 1.5 installed on Debian 8.5 with irc.server.freenode.ipv6 option set to on:

10:57:15  weechat     | [server] (irc.conf)
10:57:15  weechat     |   irc.server.freenode.ipv6 = on  (default: (undefined))
10:57:15  weechat     | 
10:57:15  weechat     | 1 option (matching with "irc.server.freenode.ipv6")

This should force WeeChat to prefer IPv6 over IPv4. irc.freenode.net has IPv6 AAAA records present:

$ dig @8.8.8.8 -t AAAA irc.freenode.net +noall +short
chat.freenode.net.
2a00:1a28:1100:11::42
2a01:270:0:666f::1
2a01:7e00::f03c:91ff:fee2:413b
2001:6b0:e:2a18::118
$ 

..and for example I'm able to ping irc.freenode.net over IPv6:

$ ping6 -nc 4 irc.freenode.net
PING irc.freenode.net(2001:5a0:3604:1:64:86:243:181) 56 data bytes
64 bytes from 2001:5a0:3604:1:64:86:243:181: icmp_seq=1 ttl=51 time=141 ms
64 bytes from 2001:5a0:3604:1:64:86:243:181: icmp_seq=2 ttl=51 time=141 ms
64 bytes from 2001:5a0:3604:1:64:86:243:181: icmp_seq=3 ttl=51 time=142 ms
64 bytes from 2001:5a0:3604:1:64:86:243:181: icmp_seq=4 ttl=51 time=142 ms

--- irc.freenode.net ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3004ms
rtt min/avg/max/mdev = 141.567/141.903/142.081/0.431 ms
$ 

However, when I try to connect to irc.freenode.net in WeeChat, then IPv6 is not even tried (checked with tcpdump). Even if I reject connections on IPv4 to TCP port 6667, then IPv6 is not tried.

I assume that the problem is not with the WeeChat (I even tried with different versions). Any ideas, what might cause such behavior?

  • 1
    i found this issue tracker, github.com/weechat/weechat/issues/558 – 林果皞 Sep 26 '16 at 11:36
  • I also read that but I don't use IPv6 address from fd00::/8 allocation. I have a global unicast IPv6 address which is used as a source IPv6 address(confirmed with ip -6 route get 2001:5a0:3604:1:64:86:243:181). – Martin Sep 26 '16 at 15:24
  • 1
    Does telnet -6 irc.freenode.net 6667 connect correctly? – Martin Sugioarto Sep 28 '16 at 11:48
  • @MartinSugioarto Yes. I see Trying 2001:6b0:e:2a18::118..., Connected to chat.freenode.net., :leguin.freenode.net NOTICE * :*** Checking Ident, :leguin.freenode.net NOTICE * :*** Found your hostname, etc messages. – Martin Sep 28 '16 at 12:13
  • Did you take a look if the answers about the address resolution precedence help you? – Martin Sugioarto Sep 28 '16 at 19:33
3
+100

Could you please try with weechat 1.6-rc2 (current devel version)? I fixed a bug with host address during connection to servers. By the way, version 1.6 is scheduled in 2 days.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.