2

some time ago I moved from Systemd to OpenRC. It was very different, to be able to use audio and webcam I had to add my user to the audio, optical and video group. As some software uses pkexec to be run as superuser, when I opened them (Because I use XFCE) nothing happened. When I used Systemd this didn´t happened, and it´s configured to use /usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 (which I have it installed). When I write pkexec in a terminal this is the output

$ pkexec
==== AUTHENTICATING FOR org.freedesktop.policykit.exec ===
Authentication is required to modify fingerprint authentication data
Authenticating as: (MY USERNAME)
Password:
polkit-agent-helper-1: error response to PolicyKit daemon: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: No session for cookie
==== AUTHENTICATION FAILED ===
Error executing command as another user: Not authorized

This incident has been reported.

I don´t know how to enable the polkit daemon/service in OpenRC, in Systemd the service it´s named "polkit". But there is ConsoleKit (what´s the difference?) which is seems to fail

$ service consolekit status
 * status: stopped
# service consolekit restart
 * starting consolekit . .
$ service consolekit status
 * status: crashed

My distro is Parabola (Arch Based, with the difference that is removes all the nonfree packages from the repo & Arch itself, as Arch uses Systemd, Parabola too) and I changed to OpenRC in a virtual machine, and I am testing it.

Thanks in advance

Other outputs

$ groups
wheel network video audio storage polkitd $USERNAME
0

I dunno what packages you are using, but you probably need polkit-consolekit and maybe some others too.

Here is a guide to switch from systemd to OpenRC for Manjaro (Arch like distro): https://wiki.manjaro.org/index.php?title=OpenRC,_an_alternative_to_systemd

  • I could solve my problem by using a display manager that supports consolekit (e. g. sddm-consolekit, lxdm-consolekit, mdm-nosystemd) – Megver83 Oct 8 '16 at 17:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.