I want to use my old Genius MousePen 8x6 graphics tablet with my notebook running Debian stretch (testing) amd64 and Gnome 3.20. The tablet was already working before I reseted the OS, now it isn't. The tablet LED flashes if I touch it with the pen, but the coursor doesnt move and no clicks are recognized. (even in libinput-debug-events)

~ % lsusb
Bus 002 Device 009: ID 5543:0005 UC-Logic Technology Corp. Tablet WP8060U

(lsusb -v here: http://nopaste.linux-dev.org/?1119974).

 ~ % xinput list  
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ RAPOO RAPOO 5G Wireless Device            id=11   [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=14   [slave  pointer  (2)]
⎜   ↳ UC-LOGIC Tablet WP8060U Mouse             id=9    [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]

Usually the tablet is shown up here as two devices: UC-LOGIC Tablet WP8060U Mouse and UC-LOGIC Tablet WP8060U Pen. The first device is for the optional mouse (I dont own it, so I cant try), the second one for the pen, which is not working.

What I also found (and what I think is most important):

% sudo libinput-ist-devices 
libinput error: libinput bug: Device 'UC-LOGIC Tablet WP8060U Pen' does not meet tablet criteria. Ignoring this device.
Device:           UC-LOGIC Tablet WP8060U Mouse
Kernel:           /dev/input/event15
Group:            4
Seat:             seat0, default
Capabilities:     pointer 
Tap-to-click:     n/a
Tap-and-drag:     n/a
Tap drag lock:    n/a
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: disabled
Calibration:      n/a
Scroll methods:   button
Click methods:    none
Disable-w-typing: n/a
Accel profiles:   flat *adaptive
Rotation:         n/a

I booted a live Lubuntu 16.04, there worked the tablet without problems, in xinput list and libinput-list-devices were both devices shown.

So, what can I do to fix this?

1 Answer 1


I don't have a fix but after half a day of frustration I think I have a work-around for you if you are using Debian 8 ("Stretch").

I had exactly the same symptoms:

  • UC-LOGIC Tablet WP8060U Mouse and Pen both working under (K)ubuntu, then after a disasterous upgrade to the latest LTS, the pen device disappeared after switching to Debian 8 (using xserver-xorg 1:7.7+18).
  • libinput writes a message to /var/log/Xorg.0.log saying that it can't handle the pen device because of an internal bug.
  • Installation of xserver-xorg-input-evdev looks like a good option because it reports catching the pen device, but shortly afterwards libinput attempts to hook onto it, suffers from the internal error, and disables the device.

My workaround was to:

  1. Install xserver-xorg-input-evdev
  2. Put the following stanza in /etc/X11/xorg.conf (this is actually my xorg.conf in its entirety):
    Section "InputClass"
       Identifier "evdev tablet catchall"
       MatchIsTablet "on"
       MatchDevicePath "/dev/input/event*"
       Driver "evdev"

This clearly is a libinput bug: it is even logged as such to the log file. Hopefully somebody will fix it one day and then the tablet pen will Just Work (TM).

Hope this helps.

  • Thanks! Its working fine. But I have one more question: the tablet is now in absolute mode (when I tap at the top left corner of the tablet the cursor jumps to the top right corner of the screen). That behaviour colud be compared to a touch screen, But what I want is somethin like a relative mode (comparable to a touch pad): when you put the pen somwhere on the tablet the cursor should not move. First if you move the pen e.g. to the right, the cursor should move to the right. There are some guides, e.g. this one (1/2)
    – tr01
    Commented Jan 6, 2017 at 11:31
  • But they do not work. If I configure my tablet analog to that guide, its still in some kind of absolute mode, the cursor jumps if I touch the tablet somewhere. And it goes a bit crazy. What can I do to get that working? (2/2)
    – tr01
    Commented Jan 6, 2017 at 11:38
  • Mine works like that too. It's actually how I prefer it for photo editing. I hover the pen to move the cursor, touch to draw etc. Mine came with a mouse too, so I can switch back and forth between that and the pen. I've not tried the other input modes. Sorry. Do post here if you find out how! Commented Jan 7, 2017 at 13:22
  • Thanks! But I think I just forgor to reboot / log in and off after configuring. I'll try again.
    – tr01
    Commented Jan 8, 2017 at 15:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .