As some may know, Firefox 49 now includes the Google Widevine CDM for Linux!!! This works perfectly for viewing some encrypted streams such as the ones here: http://demo.castlabs.com/, however when trying to watch the streams on Netflix or Amazon Video I run into trouble.

With Netflix I am told to install the Silverlight plugin and with Amazon I just get an error which send me to the help page advising me to update Google Chrome.

I assume I need to switch my user agent for this which I do know how to do, though I cannot find one which works. Has anyone found a user agent which will allow Netflix and/or Amazon Video to work?

2 Answers 2


This one worked for me for Netflix:

Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/41.0.2227.0 Safari/537.36

But it doesn't work for Amazon. On Amazon the window expands but no video player ever launches.

(Mint 18, Firefox 49 from MintUpdate. I had to enable DRM content, of course.)

  • Doesn't work for me. I get an error Error Code: M7361-1253. Sep 25, 2016 at 13:59
  • 1
    Per the Arch Wiki, at the time of writing, you need to disable sandboxing by setting MOZ_DISABLE_GMP_SANDBOX=1 in the environment that starts Firefox. Maybe Ubuntu already does this. I see a lot of instructions online that leave this out that are aimed at Ubuntu. It is necessary at least on Arch.
    – ws_e_c421
    Oct 1, 2016 at 14:33
  • Sorry, a little more reading would have explained the Ubuntu discrepancy. As described in this bug, changes to the Linux kernel in version 4.5 affected Mozilla's sandboxing. The current LTS version of Ubuntu uses version 4.4 of the Linux kernel, so it is not affected. According to the bug, it has already been fixed, so that environment variable should no longer be necessary in upcoming versions of Firefox (the bug doesn't specify which version, maybe 50).
    – ws_e_c421
    Oct 1, 2016 at 16:52

Did you fully restart Firefox after upgrading? You still h ave to install the Widevine plugin.

I had zero problem on Amazon Video, restarted Firefox, went to Amazon, started playback, and was immediately prompted to download and install Widevine.

On Netflix, I had to install the User-Agent switcher extension, and use the following User-Agent String: "Linux / Chrome 53: Mozilla/5.0 (X11; Ubuntu; Linux x86_64) AppleWebKit/535.11 (KHTML, like Gecko) Chrome/53.0.2785.34 Safari/537.36"

After restarting Firefox and refreshing Netflix, I was able to play without a problem. This solution sucks, though, as other sites will break with that user-agent set, so I'd encourage you to contact Netflix and complain.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.