0

I am experimenting my Debian 8.5 Intel graphics with Mathematica 11 student edition, and I cannot find a reason why many of the basic graphic objects are blank, although I have cleared (Clear[pic]) objects and killed the kernel (Quit kernel) from the menu Evaluation again and again. Test code

pic = Image[{{0., 1., 0.}, {1., 0., 1.}, {0., 1., 0.}}];
(* https://reference.wolfram.com/language/ref/SurfaceData.html > last Neat Example*)
With[{surf = 
   SurfaceData[Entity["Surface", "PeriodicSurface"], 
     "ParametricEquations"][1]}, 
 ParametricPlot3D[surf[u, v], {u, -0.4, 0.4}, {v, -0.4, 0.4}, 
  PlotStyle -> Texture[pic], MeshStyle -> Opacity[0.15], Axes -> None,
   Boxed -> False, Lighting -> "Neutral"]]

Fig. 1 Blank Output and Expected example on Left-hand-side and Right-hand-side, respectively

enter image description here

OS: Debian 8.5
Linux kernel: 4.6 of backports
Hardware: Asus Zenbook UX303UA
Mathematica: 11

0

This is a bug in Mathematica 11.0 on Linux systems. Mathematica 11.0.1 came out which cleans up the situation, but there has been now serious network problems for the distribution of the latest software to engineers for a couple of days, so I have not managed to troubleshoot further.

My initial test case was accepted by Wolfram for further troubleshooting of the case in 3D objects on Linux.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.