-3

here is what I'm trying to do

cd lorcon
./configure --libdir=/usr/lib
make
make install

cd pylorcon2
python setup.py build
python setup.py install
cd ../ruby-lorcon/
ruby extconf.rb
make
make install

everytime that I do followed by ruby "make" I have the following message :

root@kali:~/lorcon/ruby-lorcon# make
compiling Lorcon2.c
In file included from Lorcon2.c:5:0:
/usr/include/ruby-2.3.0/ruby/backward/rubysig.h:14:2: warning: #warning rubysig.h is obsolete [-Wcpp]
 #warning rubysig.h is obsolete
  ^~~~~~~
Lorcon2.c: In function ‘Lorcon_capture_next’:
Lorcon2.c:535:2: error: ‘TRAP_BEG’ undeclared (first use in this function)
  TRAP_BEG;
  ^~~~~~~~
Lorcon2.c:535:2: note: each undeclared identifier is reported only once for each function it appears in
Lorcon2.c:539:2: error: ‘TRAP_END’ undeclared (first use in this function)
  TRAP_END;
  ^~~~~~~~
Makefile:239: recipe for target 'Lorcon2.o' failed
make: *** [Lorcon2.o] Error 1

I tried to reinstall Ruby but no luck.

How can I install this successfully?

1

the new version of airdrop-ng requires to run

python setup.py build  
python setup.py install

instead.

0

I encountered the same problem when making airdrop.

For this, I just manually commented out the line 535, 539, and make the file

Lorcon2.c #ifndef RUBY_19
// TRAP_BEG;
#endif
ret = pcap_dispatch(pd, 1, (pcap_handler) rblorcon_pcap_handler, (u_char *)&job);
#ifndef RUBY_19
// TRAP_END;
#endif

0

BTW, airdrop can now be installed without re-building it.

apt-get install aircrack-ng
cd /usr/src/lorcon/ruby-lorcon/aircrack-ng/scripts/airdrop-ng/
./airdrop-ng

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.