1

it's me again. Unfortunately while I was trying to install another repo, I broke the original yum repo, and now an error message shows up:

Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager

https://cdn.redhat.com/content/beta/rhel/server/7/x86_64/rhscl/1/os/repodata/repomd.xml.asc: [Errno 14] HTTPS Error 404 - Not Found Trying other mirror. To address this issue please refer to the below knowledge base article

https://access.redhat.com/articles/1320623

If above article doesn't help to resolve this issue please open a ticket with Red Hat Support.

rhel-server-rhscl-7-beta-rpms | 4.0 kB 00:00:00

One of the configured repositories failed (Red Hat Software Collections Beta RPMs for Red Hat Enterprise Linux 7 Server), and yum doesn't have enough cached data to continue. At this point the only safe thing yum can do is fail. There are a few ways to work "fix" this:

 1. Contact the upstream for the repository and get them to fix the problem.

 2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

 3. Disable the repository, so yum won't use it by default. Yum will then
    just ignore the repository until you permanently enable it again or use
    --enablerepo for temporary usage:

        yum-config-manager --disable rhel-server-rhscl-7-beta-rpms

 4. Configure the failing repository to be skipped, if it is unavailable.
    Note that yum will try to contact the repo. when it runs most commands,
    so will have to try and fail each time (and thus. yum will be be much
    slower). If it is a very temporary problem though, this is often a nice
    compromise:

        yum-config-manager --save --setopt=rhel-server-rhscl-7-beta-rpms.skip_if_unavailable=true

failure: repodata/repomd.xml.asc from rhel-server-rhscl-7-beta-rpms: [Errno 256] No more mirrors to try. https://cdn.redhat.com/content/beta/rhel/server/7/x86_64/rhscl/1/os/repodata/repomd.xml.asc: [Errno 14] HTTPS Error 404 - Not Found

Anyone know how I do fix this problem? I already removed the other repo that had the problem.

Edit: used wget, and this is what's returned:

wget https://cdn.redhat.com/content/beta/rhel/server/7/x86_64/rhs‌​cl/1/os/repodata/rep‌​omd.xml.asc

--2016-09-22 14:52:19-- https://cdn.redhat.com/content/beta/rhel/server/7/x86_64/rhs%E2%80%8C%E2%80%8Bcl/1/os/repodata/rep%E2%80%8C%E2%80%8Bomd.xml.asc Resolving cdn.redhat.com (cdn.redhat.com)... 173.222.216.251 Connecting to cdn.redhat.com (cdn.redhat.com)|173.222.216.251|:443... connected. ERROR: cannot verify cdn.redhat.com's certificate, issued by ‘/C=US/ST=North Carolina/O=Red Hat, Inc./OU=Red Hat Network/CN=Red Hat Entitlement Operations Authority/emailAddress=ca-support@redhat.com’: Self-signed certificate encountered. To connect to cdn.redhat.com insecurely, use --no-check-certificate'. --2016-09-22 14:52:19-- https://cdn.redhat.com/content/beta/rhel/server/7/x86_64/rhs%E2%80%8C%E2%80%8Bcl/1/os/repodata/rep%E2%80%8C%E2%80%8Bomd.xml.asc Connecting to cdn.redhat.com (cdn.redhat.com)|173.222.216.251|:443... connected. ERROR: cannot verify cdn.redhat.com's certificate, issued by ‘/C=US/ST=North Carolina/O=Red Hat, Inc./OU=Red Hat Network/CN=Red Hat Entitlement Operations Authority/emailAddress=ca-support@redhat.com’: Self-signed certificate encountered. To connect to cdn.redhat.com insecurely, use--no-check-certificate'.

1

I noticed the same thing recently with the Red Hat Developer Subscription. Most of the default subscription repositories aren't needed at all, and as you can see at least one of them doesn't even work. Your best bet is to disable the problematic repository, as detailed in the error output you posted.

yum-config-manager --disable rhel-server-rhscl-7-beta-rpms

Even better, to avoid downloading a large amount of unnecessary repo data, disable all the repos, and the just enable the base repo.

yum-config-manager --disable '*'
yum-config-manager --enable rhel-7-server-rpms

You also might consider enabling rhel-7-server-optional-rpms and rhel-7-server-extras-rpms, which have useful things such as docker and *-devel packages.

0

Try cleaning things up with yum clean all, see if that helps.

  • Tried, doesn't work. Matter of fact, when I listed all my enabled repos, it says all of them are 404 not found error. I wonder if this have nothing to do with yum, maybe something on my system is blocking it? – Harvey Lin Sep 22 '16 at 21:46
  • A quick wget of a url would help test this, and give some debugging info e.g. wget https://cdn.redhat.com/content/beta/rhel/server/7/x86_64/rhscl/1/os/repodata/repomd.xml.asc, also check that DNS is still functional ? – steve Sep 22 '16 at 21:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.