1

I use Nginx on Ubuntu 16.04 for using Guacamole as RDP clientless. This is working perfectly on my computer which is in an external LAN. But not working in another external LAN which have proxy (work area).

When I go to the app from my browser : http://myserverguaca/guacamole/ I can see log-in page and I can log on. But when I try to start the RDP there is a loading, then a message that says:

The server take to many to time to be respond.

Do you think I have to forward another port ? I have forwarded the port 8080 to 80, RDP use : 3389, but this is in localhost, don't know why I should forward this too and how I can do it.

There is the configuration of my RDP access (user-mapping.xml)

<user-mapping>
<connection name="rdp">
<protocol>rdp</protocol>
<param name="hostname">localhost</param>
<param name="port">3389</param>
<param name="server-layout">fr-fr-azerty</param>
<param name="ignore-cert">true</param>
</connection>
</user-mapping>

and my config on nginx (sites-enabled/guacamole)

server {
listen 80;
server_name vpsmyserver.net.com;

location /guacamole/ {
proxy_pass http://localhost:8080/guacamole/;
proxy_buffering off;
proxy_http_version 1.1;
proxy_set_header X_Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header Upgrade $http_upgrade;
proxy_set_header Connection $http_connection;
access_log off;
}
}
0

In user-mapping.xml, you can add

param name="security" nla   

If it doesn't work, add the username and password of your RDP connection.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.