0

Recently I've been playing around with qemu, kvm and VFIO on an Arch Linux machine. My goal is to jump on the train of people using Linux host machines and creating a Windows 10 Pro guest VM to game on.

PCI passthrough is working great, and the benchmarks for my GPU on the guest machine are right inline with other published results. The problem I'm running into is with CPU performance.

My setup has a Intel i7 6800k. On the host machine, GeekBench gave me a result of 4129 (single core) and 15669 (multi-core). With the following QEMU script, I'm unable to get a CPU score of above 6260 with any modification I make to the smp parameter. This includes...

Throughout the entire test, I could never get the Windows VM to register more than 2 Sockets and 2 Virtual Processors. I'm guessing this has something to do with the fact the Windows OS knows it's a VM since there's no mention of cores or logical processors.

Anyone know of any configuration settings I'm missing to get windows to register the additional cores I'm specifying and help improve my VMs CPU performance?

Oh, and here's a list of the current modules I have installed and configured on the host machine.

Thanks!

  • So everything works ok except with Windows 10? Can you please specify what the problem is? – Greg Askew Sep 22 '16 at 0:01
  • The smp argument in qemu "Simulates an SMP system with n CPUs". I'm wondering why I seeing little to no difference in my guest performance and configuration when I vary "n" in the ways that I've listed. – Staros Sep 22 '16 at 0:09
  • This is not an answer but an observation. Generally, modern games do not yet utilize multi-core CPUs. They typically run single-threaded. One reason that i5 gaming machines are so great is that you can drop hundreds from the price without losing performance. So, unless your goal is perfecting the benchmarks, I'd suggest trying your games within your VM and determining whether the performance is acceptable. – Xalorous Sep 22 '16 at 0:46
  • @Xalorous You're correct. At this point this is more for science and understanding qemu. – Staros Sep 22 '16 at 0:55
0

I've upgraded to QEMU version 2.7.50 and now Windows 10 (Anniversary edition) registers the sockets, cores and threads I specify.

  • If this problem is solved, please mark it as solved by clicking the outline of the check mark so that it turns green. – Michael Hampton Sep 6 '18 at 1:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.