1

I have 3 GPUs in my dual XEON server.

I followed instructions on Arch wiki and set up vfio-pci with ids=10de:100c,10de:0e1a:

$ modprobe -c | grep vfio
options vfio_iommu_type1 allow_unsafe_interrupts=1
options vfio_pci ids=10de:100c,10de:0e1a
...

But according to dmesg vfio ignores that option:

[    1.278976] VFIO - User Level meta-driver version: 0.3
[    1.306193] vfio_pci: add [1002:7142[ffff:ffff]] class 0x000000/00000000
[    1.326139] vfio_pci: add [1002:7162[ffff:ffff]] class 0x000000/00000000

Moreover when I unplugged card with 1002:7142 and 1002:7162 devices on-board and reboot I still have such entries in dmesg output and no more!

I upgraded linux kernel version and vfio_pci started to add another card but still independent in ids option!

I don't know what to do to resolve that problem. I want to setup certain GPU to be add as vfio_pci device. I don't even know where to look.

List of GPUs:

#IOMMU group 17
#  02:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti XT [Radeon HD 7970/8970 OEM / R9 280X] [1002 :6798]
#  02:00.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Tahiti XT HDMI Audio [Radeon HD 7970 Series] [1002:aaa0]
#IOMMU group 18
#  03:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK110B [GeForce GTX TITAN Black] [10de:100c] (rev a1)
#  03:00.1 Audio device [0403]: NVIDIA Corporation GK110 HDMI Audio [10de:0e1a] (rev a1)
#IOMMU group 30
#  83:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] RV515 PRO [Radeon X1300/X1550 Series] [1002:7142]
#  83:00.1 Display controller [0380]: Advanced Micro Devices, Inc. [AMD/ATI] RV515 PRO [Radeon X1300/X1550 Series] (Secondary) [1002:7162]

Modprobe settings:

$ cat /etc/modprobe.d/vfio.conf
options vfio-pci ids=10de:100c,10de:0e1a

Linux version:

$ uname -a
Linux localhost 4.4.21-1-lts #1 SMP Thu Sep 15 20:38:36 CEST 2016 x86_64 GNU/Linux
  • Can you show the output of lspci -s 02:00.0 -vk ? – Alec Istomin Sep 28 '16 at 18:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.