On Debian (Jessie) 8 I added the backports source and installed a newer kernel via:

apt-get update
apt-get install -t jessie-backports linux-image-amd64

I then ran


However on reboot I do not see an option in GRUB to select the new kernel and the usual option loads the existing kernel:

uname -r

Firstly can I just update the kernel like this without recompiling all the software? (I want a new kernel in the hope it supports my hardware)

Second, if so, how do I make it appear in GRUB?

  • update-grub only updates the grub files that are used to build the grub configuration. You forgot to do grub-install, most common is grub-install /dev/sda. Make sure you are using kernel 4.7 from the backports. – Rui F Ribeiro Sep 21 '16 at 14:19
  • @RuiFRibeiro thanks - that put the entry in GRUB :) When I choose it I just get a black screen so it seems I haven't done the upgrade correctly (pressing power off does gracefully power off). – Kris Sep 22 '16 at 8:09
  • 1
    It was the graphics driver, if I booted with nomodeset (by pressing e on the Debian option and adding nomodeset in the end of the line starting linux) then I got a Desktop as expected. If you want to post your answer I will accept it. – Kris Sep 22 '16 at 9:02
  • all of this should be handeld automagicaly by the package manager (apt-get) ? I've never had to update grub manually when installing kernel from debian repository .... – Mali Sep 22 '16 at 11:13
  • 1
    @Mali I had to update grub because of my video card. Once I booted successfully in to the desktop for the first time all was well. I'm guessing the desktop was using the wrong videomode initially. – Kris Sep 23 '16 at 11:42

Alas, expecting update-grub to work and create the grub boot-time tidbits is a common mistake I also made as a rookie.

update-grub only updates the grub files that are used to boot the grub configuration.

You have to do grub-install ; the most common of reinstalling/fixing grub is:

From Grub2/Installing - Post-Restoration Commands

To refresh the available devices and settings in /boot/grub/grub.cfg:

sudo update-grub

To look for the bootloader location.

grub-probe -t device /boot/grub

To install GRUB 2 to the sdX drive's MBR or boot sector (sda, sdb, etc.)

sudo grub-install /dev/sda

Since you are installing from the Debian backports, make sure you are using the latest kernel, which should be at the time of this post kernel 4.7.

  • 1
    grub-probe is a nice tip. – Kris Sep 22 '16 at 9:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.