1

My router broke down(ordered another but it will take weeks to arrive) so I had to setup an old netbook to do the job temporarily. It's running Windows 10's(I couldn't get hotspots working on Linux) native hotspot program. I can connect game consoles, phones and computers(the limit seems to be 100 devices, and I had 5 devices connected at once), but not this one laptop. I know the networking works because I'm using my Android's hotspot ATM.

Now this laptop is running Arch, tried Netctl, Wicd and NetworkManager and the two former connected to the hotspot but couldn't obtain IP address. I then tried some live disks I had laying around(Kali and Mint) and both had the same problem as Arch.

$ lspci -knn | grep Net -A2
00:19.0 Ethernet controller [0200]: Intel Corporation 82567LM Gigabit Network Connection [8086:10f5] (rev 03)
Subsystem: Fujitsu Limited. Device [10cf:14ad]
Kernel driver in use: e1000e
--
20:00.0 Network controller [0280]: Intel Corporation Ultimate N WiFi Link 5300 [8086:4235]
Subsystem: Intel Corporation Device [8086:1101]
Kernel driver in use: iwlwifi



$ ifconfig
wlp32s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
    inet 192.168.43.64  netmask 255.255.255.0  broadcast 192.168.43.255
    inet6 fe80::221:6aff:fe25:7a60  prefixlen 64  scopeid 0x20<link>
    ether 00:21:6a:25:7a:60  txqueuelen 1000  (Ethernet)
    RX packets 2663  bytes 2035423 (1.9 MiB)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 2601  bytes 427106 (417.0 KiB)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

(it is connected right now to a different hotspot)

$ iptables -S 

-P INPUT ACCEPT
-P FORWARD ACCEPT
-P OUTPUT ACCEPT

Tried ifconfig up / down, iwconfig power off, played around with modprobe configs(deleted now)...

The settings of the hotspot seem fairly standard, nothing Linux would have problems with(since Android and PS4 are fine with it).

I'm not sure which logs or outputs exactly would be helpful in this situation...

Thanks!

1

You need to install the linux-firmware package

Load the iwlwifi module:

modprobe iwlwifi 11n_disable=1 swcrypto=1 

Then create a /etc/modprobe.d/iwlwifi.conf file with the following contents:

options iwlwifi 11n_disable=1
options iwlwifi swcrypto=1
  • I tried those modprobe confs earlier with no luck. linux-firmware is installed. Thanks still. – Jareg Sep 20 '16 at 20:42
  • 1
    Are you sure you shouldn't be doing the modprobe after you've set up the configuration file for loading the module? – roaima Sep 20 '16 at 21:38
  • @Jareg Please edit your question by adding the output of lspci -knn | grep Net -A2 – GAD3R Sep 20 '16 at 21:50
  • @roaima Tried doing it both ways, still wouldn't work :-( – Jareg Sep 20 '16 at 22:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.