16

I'm getting an error while trying to install Kali Linux 2016.2 64 Bit in my VMware machine.

An installation step failed. You can try to run the failing item again from the menu, or skip it and choose something else. The failing step is: Install the system

I've downloaded kali-linux-2016.2-amd64.iso torrent from Kali Linux's official website www.kali.org/downloads/

I've created Virtual machine by selecting Linux > Debian 8.x 64-Bit

I Gave Virtual Machine 30.00 GB Hard drive space and 2.00 GB Ram.

  1. Booted up the iso and selected Graphical Install
  2. After Completing few step then I came up to Partition Disks step.
  3. I've selected "Guided - use entire disk" then clicked continue.
  4. Then I select the Hard disk and clicked continue
  5. In Partitioning scheme I've selected All files in one partition (recommended for new users)
  6. Then the following message came:

    The following partitions are going to be formatted:
    
     partition #1 of SCSI3 (0,0,0) (sda) as ext4
     partition #5 of SCSI3 (0,0,0) (sda) as swap
    
     write changes to disks?
     yes or no
    

    I selected yes and clicked continue and installation was going well.

  7. But after a few moments Kali Linux installation stuck and showed me an error as stated below:

    An installation step failed. You can try to run the failing item again from the menu, or skip it and choose something else.
    The failing step is: Install the system
    

    See the screenshot: http://i.imgur.com/GPklG37.png

If I click continue then after a while the error reappears. I tried a lot of time to install but failed everytime.

My System:

Processor: Intel(R) Core(TM) i5 CPU M430 @2.27GHz Ram: 8.00 GB Graphics: ATI Mobility Radeon HD 5470 OS: Windows 7 Home Premium, 64-bit 6.1.7601, Service Pack 1

My VMware:

Version: 12.1.0 build-3272444 (64Bit)

13
  • 1
    Why install? Download image: offensive-security.com/… Sep 20 '16 at 19:07
  • VMware Image version is 2016.1 but current Kali Linux version is 2016.2 and I also found that people are having similar problem with their physical computer also.
    – Shateel
    Sep 20 '16 at 22:58
  • There is exist one magic command: apt-get. It can transform 2016.1 to 2016.2 in one command. Sep 21 '16 at 1:00
  • Yeah! I know it, but why I can't able to install it in VMware that makes me mad, I'm geek so I've to figure out the problem with the help of other! not only me I searched over internet and there's a lot of people facing same kind of problem while installing Kali Linux either in VM or Physical Machine! I need to figure out this kali linux installation problem because I thought after I install it to VMware then I would install it to my system! But I'm failing install it to VMware. Thanks
    – Shateel
    Sep 21 '16 at 1:13
  • Kali is a rolling distro which based on debian testing, so it is always in beta phase. Fill a bugreport at kali site, then be patient. It is the normal behavior a beta system. If you have power+time, feel free to fix it then share the patch. Kali is not a stable distribution, you have to deal with it. Minor and major bugs are totally normal and not your fault. Sep 21 '16 at 1:16
17

I had the same problem, and I have fixed it by increasing the space for the hard drive. By default you have 8 GB, increase it to 30 GB or more. And continue with the installation.

1
  • 3
    I did that thingi, but didn't solve my problem:(
    – Shateel
    Feb 2 '17 at 17:42
3

A quick solution might be specifying file system usage, meaning is that using a single container not a seperated for /usr, /var, /tmp ..

1
  • 2
    Installation failed on trying to use separated partitions, but as suggested using single partition succeeded.
    – user234725
    Oct 16 '18 at 12:10
2

I faced exactly the same predicament as your's and extensive search on internet did not yield any straight-forward answer.

My host OS level(Windows 7), VMWare version and Kali linux version & settings for Kali install attempt are similar to yours with the exception - that I did chose separate partition for /home, /var & /temp - I chose varying disk capacity size which you chose as 30G

While trying repeatedly to install with differing settings I noticed following pattern: - for 8G disk capacity setting the install step failed after approx. 20% completion - for 20G disk capacity setting the install step failed after approx. 40% completion - for 40G disk capacity setting the install step failed after approx. 80% completion

Finally the install step succeeded with 60G disk capacity value. So try increasing your disk capacity and give it a shot!

4
  • I tried with 60GB still it's a failure...
    – Shateel
    Mar 20 '17 at 23:04
  • 3
    Are you kidding me? 60 GB for a Kali installation? I'm giving it 8 and its a lot!
    – KeyC0de
    Sep 12 '17 at 12:01
  • This actually helped me. But I kept it above 30 GB and below 60 GB. 58GB to be exact.
    – Krish
    Dec 29 '19 at 13:01
  • Mine failed at 20GB and worked at 30GB. Mar 20 '20 at 5:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.