0

Hi all been at this a for a few days now and cant understand why i get the sad face after i login to vncviewer.

Details: I have two accounts "root" and "user1" now i can ssh from a windows box and start a server with root login which in turn will let me login via vncviewer and work no problems.

However if i try this method with my user1 account i get the sad face or black screen. server running details:

    ./vncserver

Desktop 'TurboVNC: rhel7pod1:1 (user1)' started on display rhel7pod1:1

Starting applications specified in /home/user1/.vnc/xstartup.turbovnc
Log file is /home/user1/.vnc/rhel7pod1:1.log

i have changed the group to "engineer" which user1 is part of but i believe that the main issue here is permissions as root runs fine?

if you need any information let me know and i will post accordingly. Many thanks

edit1: looking into the Xvnc and when i run that command i get the following:

  ./Xvnc TurboVNC Server (Xvnc) 64-bit v2.0.2 (build 20160312)
 Copyright (C) 1999-2016 The VirtualGL Project and many others (see
 README.txt) Visit http://www.TurboVNC.org for more information on
 TurboVNC

 20/09/2016 16:17:12 Using auth configuration file
 /etc/turbovncserver-security.conf 20/09/2016 16:17:12 NOTICE:
 pam-userpwd is a permitted auth method

 Fatal server error: ERROR: no authentication methods enabled!

Here is the config turbovncserver-security.conf

 # Uncomment the following to turn on the user access control list whenever
 # the PAM User/Password authentication method is used.
 # (Default: user ACL is disabled)

 #enable-user-acl

 # This specifies the maximum idle timeout (in seconds) for all TurboVNC
 # sessions started on this machine.  The idle timeout is the amount of time
 # that a TurboVNC session can remain idle (with no VNC viewer connections)
 # before it will automatically exit.  If this value is set to a number greater
 # than 0, then all TurboVNC sessions on this machine will use this idle timeout
 # value by default, and the user will only be allowed to override it with a
 # lower value.

 #max-idle-timeout = 86400

 # This specifies the maximum desktop size for all TurboVNC sessions started on
 # this machine.  If a user attempts to start a session with a larger geometry
 # than this or to use remote desktop resizing to increase the desktop size to a
 # size larger than this, the desktop size will be clamped to this width/height.

 #max-desktop-size = 3200x1800

 # Uncomment the following to globally disable the automatic sending of
 # clipboard changes from TurboVNC server sessions to their connected viewers.
 # (Default: clipboard sending is allowed)

 #no-clipboard-send

 # Uncomment the following to globally disable the automatic sending of
 # clipboard changes to TurboVNC server sessions from their connected viewers.
 # (Default: clipboard receiving is allowed)

 #no-clipboard-recv

 # Uncomment the following to globally disable the ability to make reverse
 # VNC connections.
 # (Default: reverse connections are allowed)

 #no-reverse-connections

 # Uncomment the following to globally disable inbound remote connections to all
 # TurboVNC servers started on this machine.  This effectively forces SSH
 # tunneling to be used for all inbound TurboVNC connections.
 # (Default: inbound remote connections are allowed)

 #no-remote-connections

# Uncomment the following to globally disable the built-in HTTP server in all
 # TurboVNC servers started on this machine.

 #no-httpd

 # Uncomment the following to globally disable X11 TCP connections to all
 # TurboVNC servers started on this machine.

 #no-x11-tcp-connections

 # Set pam-service-name to the name of the PAM service that you will use to
 # to process PAM User/Password authentications from TurboVNC.  This service
 # name typically corresponds to a file in /etc/pam.d or to one or more lines in
 # /etc/pam.conf.
 # (Default: turbovnc)

 pam-service-name = password-auth-ac

 # Set the following to any combination of "vnc", "otp", "pam-userpwd", or
# "none", separated by commas.  If the following variable is enabled and
 # a particular authentication method is not listed in it, then users cannot
 # enable that authentication method by using Xvnc command line arguments.  This
# variable also controls the order in which the corresponding authentication
 # capabilities are advertised to the TurboVNC Viewer.  See the man pages and
 # User's Guide for more information.
 # (Default: vnc, otp, pam-userpwd, none)

 #permitted-auth-methods = vnc, otp, pam-userpwd 
 permitted-auth-methods = pam-userpwd

Edit 1 end

EDIT 2

20/09/2016 16:38:25 Using auth configuration file /etc/turbovncserver-security.conf

20/09/2016 16:38:25 Enabled authentication method 'pam-userpwd'

20/09/2016 16:38:25 Advertising security type 'tight' to viewers

20/09/2016 16:38:25 Desktop name 'TurboVNC: rhel7pod1:3 (user1)' (rhel7pod1:3)

20/09/2016 16:38:25 Protocol versions supported: 3.3, 3.7, 3.8, 3.7t, 3.8t

20/09/2016 16:38:25 Listening for VNC connections on TCP port 5903

20/09/2016 16:38:25   Interface 0.0.0.0

20/09/2016 16:38:25 Listening for HTTP connections on TCP port 5803

20/09/2016 16:38:25   URL http://rhel7pod1:5803

20/09/2016 16:38:25   Interface 0.0.0.0

20/09/2016 16:38:25 Framebuffer: BGRX 8/8/8/8

20/09/2016 16:38:25 Maximum clipboard transfer size: 1048576 bytes

20/09/2016 16:38:25 VNC extension running!

Xlib:  extension "GLX" missing on display ":3".

gnome-session-is-accelerated: No hardware 3D support.

Xlib:  extension "GLX" missing on display ":3".

gnome-session-check-accelerated: Helper exited with code 256

Xlib:  extension "GLX" missing on display ":3".

gnome-session-is-accelerated: No hardware 3D support.

Xlib:  extension "GLX" missing on display ":3".

gnome-session-check-accelerated: Helper exited with code 256

** (process:9464): WARNING **: software acceleration check failed: Child process exited with code 1

20/09/2016 16:38:42 Got connection from client 192.168.103.17

20/09/2016 16:38:42 Using protocol version 3.8

20/09/2016 16:38:42 Enabling TightVNC protocol extensions

20/09/2016 16:38:52 Pixel format for client 192.168.103.17:

20/09/2016 16:38:52   32 bpp, depth 24, little endian

20/09/2016 16:38:52   true colour: max r 255 g 255 b 255, shift r 16 g 8 b 0

20/09/2016 16:38:52   no translation needed

20/09/2016 16:38:52 Using tight encoding for client 192.168.103.17

20/09/2016 16:38:52 Enabling full-color cursor updates for client 192.168.103.17

20/09/2016 16:38:52 Enabling cursor position updates for client 192.168.103.17

20/09/2016 16:38:52 Using JPEG subsampling 0, Q100 for client 192.168.103.17

20/09/2016 16:38:52 Using JPEG quality 95 for client 192.168.103.17

20/09/2016 16:38:52 Using JPEG subsampling 0 for client 192.168.103.17

20/09/2016 16:38:52 Enabling LastRect protocol extension for client 192.168.103.17

20/09/2016 16:38:52 Enabling Desktop Size protocol extension for client 192.168.103.17

20/09/2016 16:38:52 Enabling Extended Desktop Size protocol extension for client 192.168.103.17


20/09/2016 16:38:52 Enabling Continuous Updates protocol extension for client 
192.168.103.17

20/09/2016 16:38:52 Enabling Fence protocol extension for client 192.168.103.17

20/09/2016 16:38:52 rfbProcessClientNormalMessage: ignoring unknown encoding 
-305 (fffffecf)

20/09/2016 16:38:52 Using Tight compression level 1 for client 192.168.103.17

20/09/2016 16:38:52 Using 1 thread for Tight encoding

20/09/2016 16:38:52 Continuous updates enabled

20/09/2016 16:38:58 Client 192.168.103.17 gone

20/09/2016 16:38:58 Statistics:

20/09/2016 16:38:58   key events received 6, pointer events 41

20/09/2016 16:38:58   framebuffer updates 1, rectangles 21, bytes 19773

20/09/2016 16:38:58     LastRect markers 1, bytes 12

20/09/2016 16:38:58     cursor shape updates 1, bytes 12

20/09/2016 16:38:58     cursor position updates 1, bytes 12

20/09/2016 16:38:58     Tight rectangles 18, bytes 19737

20/09/2016 16:38:58   raw equivalent 4.464012 Mbytes, compression ratio 226.174799

Edit 2 end

  • If you're opening an SSH session anyway, why go through the extra steps of starting the vncserver as root and then logging in again graphically? just start it as your regular user. Preferably, set up a tunnel for the VNC traffic. – steeldriver Sep 20 '16 at 16:45
  • The system will be used for ssh and vnc but i need the user to be able to ssh in and start a server when they need to. It will be required for 3D Modelling hence the vnc server. the root attempt is just for testing but the users cant do it do you have any idea why? – Timbo Sep 21 '16 at 7:57
  • What sessions are you trying to start with root's versus user1's ~/.xstartup file? Try configuring your user to use a desktop session that doesn't require 3D acceleration. See bugs.launchpad.net/ubuntu/+source/gnome-session/+bug/1274013 – steeldriver Sep 22 '16 at 12:19
1

I have worked out the answer i have edited the xstartup.turbovnc script and on the second line added

startkde

thats it seems to work for any user i edit it for. seems more of a work around that a solution but i need it to work and thats it!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.