0

It looks like rsync while copying file from source to destination is changing file permissions to different i have tried all options -o,-p,-avz --no-perms --no-owner --no-group,.. no luck still rsync is doing that might be bug in rsync as it is not performing certain operations or I am missing something i want to preserve the file permissions as it is while copying.

  • It would be helpful if you could provide an example of the result and the expected result. Also please post which filesystems are in use during your copy, filesystem on source and filesystem on destination. Best would be to edit your question for that information. – Thomas Sep 20 '16 at 15:05
  • My lab setup is serv1(sunos spark enterprise) serv2(sunos spark enterprise) and at serv1 i have access to IDS namely home user and another testid,coming to serv2 same setup.How i tested as follows i created file in /tmp/sample as testid on serv1 and tried copying the same file from home user id on serv1 to serv2 by changing sample file permission to chmod666 and when i went and cross checked at serv2 the sample file permissions has changed to homeuser id of serv1.This was not the output required, as the output at serv2 should be same as testid where i created sample file. – chandu Sep 20 '16 at 15:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.