1

I have vlc v2.2.4 installed on my system it came pre-installed in my OS (Parrot Security). The problem is that this version is not stable I have problems in running .mkv files they get stuck at a point with blinking white screen (within vlc). I googled and found that this is a problem of vlc v2.2.4 and the stable version is v2.2.0.

I tried searching for vlc 2.2.0 on synaptic package manager but it only shows the latest version. So I downloaded the old version from debian's site but the file is in tar.xz format. (Don't know how to install this)

What should I do? is there any fix to the current version of vlc or should I just install the tar.xz file. If yes please tell me how.

Error after sudo make install :

Makefile:8807: recipe for target 'video_chroma/libswscale_plugin_la-swscale.lo' failed
make[4]: * [video_chroma/libswscale_plugin_la-swscale.lo] Error 1
make[4]: Leaving directory '/home/dummy/vlc-2.2.0/modules'
Makefile:9653: recipe for target 'install-recursive' failed
make[3]:
[install-recursive] Error 1
make[3]: Leaving directory '/home/dummy/vlc-2.2.0/modules'
Makefile:9982: recipe for target 'install' failed
make[2]:
[install] Error 2
make[2]: Leaving directory '/home/dummy/vlc-2.2.0/modules'
Makefile:2263: recipe for target 'install-recursive' failed
make[1]: *
[install-recursive] Error 1
make[1]: Leaving directory '/home/dummy/vlc-2.2.0'
Makefile:2729: recipe for target 'install' failed
make: *** [install] Error 2

  • Please add the output of apt-cache policy vlc – GAD3R Sep 18 '16 at 20:19
0

You can go to Debian's official packages repository, download any version ofany package you want and install it manually with dpkg.

I just checked and the stable version there is currently 2.2.4-1, which sounds weird to me, cause it can't get more stable than Debian's stable repos.

So, download it according to your architecture and install it with dpkg -i. For example, for 64bits:

sudo dpkg -i vlc_2.2.4-1-deb8u1_amd64.deb
0

Remove vlc 2.2.4

sudo apt-get remove vlc

Download Vlc 2.2.0 from here:

wget ftp://ftp.videolan.org/pub/videolan/vlc/2.2.0/vlc-2.2.0.tar.xz

Install build-essential and linux-headers ... :

sudo apt-get install build-essential linux-headers-$(uname -r)
sudo apt-get install git libtool pkg-config autoconf
sudo apt-get install lua5.2 liblua5.2-dev
sudo apt-get build-dep vlc

install vlc 2.2.0

tar xf vlc-2.2.0.tar.xz
cd vlc-2.2.0
./bootstrap
./configure
make
sudo make install

Edit

Some useful information can be founed here :wiki.videolan:UnixCompile

  • when I run make it gives me the following result -- make: *** No targets specified and no makefile found. Stop. – HeroicJokester Sep 19 '16 at 19:58
  • @HeroicJokester i edit my answer – GAD3R Sep 19 '16 at 20:42
  • I tried running the commands but it gives me the fallowing error configure: error: Could not find lua. Lua is needed for some interfaces (rc, telnet, http) as well as many other custom scripts. Use --disable-lua to ignore this error. I installed lua and ran the commands again but im getting the same error. (sorry I'm new to linux) – HeroicJokester Sep 21 '16 at 18:31
  • @HeroicJokester Run apt-get install lua5.2 – GAD3R Sep 21 '16 at 18:55
  • Did that still getting the same error. – HeroicJokester Sep 21 '16 at 19:19
0

Try this: type apt show -a vlc | grep ^Version. You'll get two things:

  1. A warning telling you that there is no "Stable CLI interface", which I assume means that future versions of apt may function differently than current versions (if I'm wrong, someone leave a comment). You should keep this in mind.

  2. It will show you all of the versions you can install. Assuming 2.2.0 is present, you should be able to run sudo apt install vlc=2.2.0-something (replace "something" with whatever apt says), and your computer will downgrade. Afterwards, you may want to mark vlc as a "held" package to prevent it from updating in the future. You can do so with apt-mark hold vlc.

If you get any package dependency issues, running sudo aptitude will give you an interactive program to help resolve those issues. You may have to install aptitude with sudo apt install aptitude.

If 2.2.0 isn't there, you won't be able to install vlc from apt (if you use a GUI, said GUI probably uses apt as a backend). Fortunately, there are other ways to install it. As user GAD3R pointed out, you can compile from source using the steps (s)he pointed out already. Or, you can install vlc via either snap or flatpak, but I find both packaging systems to be a bit on the bloated side.

You can also install an app image on your machine. This is as easy as A) download a file, B) make it executable), and C) run it. After a quick web search, I managed to find two app images: 2.2.8, and 3.0.0. It *SHOULD* be safe to install both at the same time, so you're free to see which ones work, and which ones don't. Just to be safe, you should probably install 2.2.8 first, and then try 3.0.0, since they may have incompatible settings. Unfortunately, the appimages are both amd64 images, so you won't be able to use them on a 32-bit OS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.