2

When I use my laptop on battery, no USB device I connect (i.e. memory stick, external hard drive or mouse) is recognized on either USB 2.0 or USB 3.0 ports.

I found two workarounds, which I, however, don't find satisfactory long term:

  1. Plug in the device. Go into suspend. Wake up.
  2. Connect the laptop to power. Plug in the device.

I tried to mess around with the BIOS settings, which has two options regarding USB: "Legacy USB Support" and "USB Mass Storage Driver Support". I have tried any combination of "disable" and "enable", but nothing helped.

Someone running Arch seems to have a similar problem, so could this have to do with the kernel?

My system:
Laptop: Asus Zenbook UX305UA
OS: elementary OS 0.4 Loki (based on Ubuntu 16.04 LTS)
Kernel: 4.4.0-36-generic

I have tlp installed .

EDIT: Same problem with the SD card slot.

1

Btw, I have tlp installed (I don't know if that could have to do with it...).

This may very well be the ca[u]se. I faced the same problem today after a system upgrade. I have found a workaround for this.

Plug in your drive and then run the following commands, waiting for a couple of seconds between the two:

$ sudo tlp ac
$ sudo tlp bat

These commands tell TLP to go to AC powered mode and back again to battery mode. This fixes the issue for me --- the usb drive is magically detected and (auto)mounted when TLP is in AC mode. This suggests that the underlying problem may indeed be with TLP.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.