0

I have been trying to update my Mono and Mono Compiler on my CentOS 7 server and i can't seem for the life of me to get it past 2.10.X. I have followed various guides, and even added the beta repo channel from Mono itself but it will not complete the mono-complete install command.

Even when i use

yum install mono-complete-0:4.6.0.243-0.xamarin.1.x86_64

It comes back with failed dependencies and broken packages it seems. It seems to still try to pull dependencies of 2.10.X instead of the updated ones? I am not sure what to do, to be honest. Here is a log of what happens when i run the above command.

Command Log

0

I ended up compiling mono from scratch instead, using the tar files from the download server and it worked. Funnily enough, this is embarassing but i posted a similar question 3 years ago. I tried google searching some more, and came across my own old question (that was answered) 3 years ago on stack exchange. For anyone looking on how to just compile it from scratch instead to 4.6.0 read my old thread here.

Previous Stack Exchange Thread With Answer

The only thing you need to do different is update the wget links with the latest packages from monos file server. Everything else works the same!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.