1

I have Crunchbang Linux Walforf, and while working I like to listen to music on Youtube. My laptop's speakers are, as you can imagine, suboptimal and I would like to use the JBL charge bluetooth speaker for superior experience. I have installed bluez-tools and pretty much everything that starts with bluez, as well as blueman. I run blueman-applet and I am able to discover my speaker and connect to it. Here is the screenshot of what it looks like when I am connected (right-clicked).

enter image description here

I am able to connect to "Headset Service" and "Audio Sink" but not to "Input service". As you can see from this second screenshot, the notification at the bottom of the panel states that operation is not supported.

enter image description here But the music still plays in the laptop.

Any suggestions how can I fix the problem?

  • I know nothing about Crunchbang. Do you use PulseAudio in it? If so, try pavucontrol (after connecting to the speaker) and remap the application (browser?) audio output to the new device. In my Ubuntu I also find phonon to be useful. It allows me to set the priorities of different audio devices. This way my system automatically switches audio to my BT headphones the moment I connect them. Tell me if you have these tools and how it went. – Kamil Maciorowski Sep 20 '16 at 6:57
  • I do have pavucontrol, I posted the issue with that in response to the answer below – Oposum Sep 21 '16 at 1:11
  • I'm now referring to your comments to Dmitry's answer. The right way to inform the world about your partial success and remaining problems is editing your question. In order not to make it too broad it is now justified to ask a separate question about module loading. For now you limit the number of people that may help you because hardly anyone takes the effort of reading all the comments to a question, not to mention the ones under an answer. People with a clue will: – read the question, – think of pavucontrol, – notice Dmitry has already covered this, – move on to the next question. – Kamil Maciorowski Sep 21 '16 at 4:44
1
+50

Not being able to connect to "Input" service is not an issue. It means either your BT speakers don't have a microphone, or bluez fails to configure it properly. It should not affect the playback.

Once you have connected your BT speaker in bluez (I'd recommend connecting to "Audio sink" service), it should appear in pulseaudio devices list. Install pavucontrol package if you haven't already, and start the GUI by either running pavucontrol command in the terminal or right-clicking on the speaker icon and selecting "Configure" (this may or may not work depending on your desktop environment).

Once you have PulseAudio volume control applet, check if it sees your BT speaker as an output device. If it does, make it default by clicking the green checkbox:

enter image description here

Once you set your BT speaker as default output, any new program you start should use it to play sound. You may need to restart your browser to play youtube music on it.

If your BT speaker does not show up in PulseAudio, refer to this question on Ask Ubuntu, or provide more details here so we can help you.

  • 1
    I already had pavucontrol. When I initially launched it, my bluetooth speaker was not visilbe. Then I followed your Ubuntu link and used these code lines that made the bluetooth speaker appear in the pavucontrol output panel pulseaudio -k sudo alsa force-reload Even after switching to the bluetooth speaker and observing the output bar oscillating, there was sill no audible sound. – Oposum Sep 21 '16 at 0:55
  • 1
    Finally, I was able to achive the sound by switching Built-in Audio to "Off" in the configuration tab of pavuconrol. The speakers started to work but the sound was terrible. I again went to the configuration tab of pavuconrol and switched the bluetooth speaker from Telephony Duplex (HSP/HFP) to High Fidelity Playback (A2DP) which solved the sound quality problem. – Oposum Sep 21 '16 at 2:31
  • 1
    After rebooting (to see if everything still works), I am able to connect to the bloetooth speaker's "headset device" but not to the "audio sink". Attempt to connect to the audio sink generates the message "Connection Failed: Stream setup failed" – Oposum Sep 21 '16 at 2:41
  • 1
    After entering the command pactl load-module module-bluetooth-discover I was finally able to connect to the audio sink. What a pain... – Oposum Sep 21 '16 at 2:48
  • 1
    I guess all I need to figure out now is how to automate the process so that I don't have to manually enter pactl load-module module-bluetooth-discover every time. I followed the most voted respone on your link (editing files /etc/pulse/default.pa and /usr/bin/start-pulseaudio-x11) but no change. – Oposum Sep 21 '16 at 3:11
1

You need the pulseaudio-module-bluetooth package, then you can easily select the desired sound output

  • I'd expect the OP to have this package already, otherwise his BT speaker wouldn't work at all. – Dmitry Grigoryev Sep 21 '16 at 16:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.