3

I used VirtualBox version 5.1.6 to install Kali Linux 2016.2 x64 as a VM.

I made sure my system was up-to-date:

sudo apt-get update && sudo apt-get upgrade -y

I grabbed the VirtualBox Guest Additions:

sudo apt-get install -y virtualbox-guest-x11

Set up the following functionality:

Settings(Host + S) -> General -> Advanced:

Shared Clipboard: Bidirectional

Drag and Drop: Bidirectional

Then I rebooted the system; reboot.

Tried to drag and drop a directory from the Host to the Guest and nothing happened.

1 Answer 1

4

I'm running Kali-Linux-2017.1-vbox-amd64 and updated && upgraded it and faced the same issue as you. I fixed it by adding the following command at the end of the ~/.bashrc file:

# Enable VirtualBox Clipboard 
VBoxClient --clipboard

Type in the command to your terminal or restart it (the terminal) and your clipboard will work once again.

3
  • 2
    Occasionally VirtualBox's shared clipboard will stop working. For me I notice that it stops working after my host OS (Mac) password protected screensaver starts. While rebooting the guest OS will resolve the situation, killing and restarting the VBoxClient --clipboard command will get the clipboard capability back. ps -ef | grep VBoxClient | grep clip kill -9 [the PIDs] VBoxClient --clipboard
    – user503821
    Jan 13, 2018 at 11:02
  • 1
    This doesn't work. In addition it produces error.
    – KeyC0de
    Apr 3, 2018 at 19:28
  • The instructions from user503821 work. You need to run ps -ef | grep VBoxClient | grep clip, then observe the PIDs, then run the kill and VBoxClient --clipboard commands with sudo or as root. May 1, 2020 at 5:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.