0

The following has happened:

  1. On my primary SSD I have Windows 10 Pro (BIOS is in Legacy + UEFI mode)
  2. I installed a new, seperate drive and attempted to install Linux Mint on it
  3. Install fails as Grub can't install bootloader
  4. Install reFind
  5. Re-install Linux Mint, this time it works but it also installs Grub2

The situation I am now in:

  • Grub is the default boot loader. Can load into Mint fine. Shows entry for Windows under /dev/sda2 but won't load
  • I can go into my BIOS boot order and select "Windows Boot Manager" which loads up reFind and allows me to boot into Windows, Mint or "Ubuntu" (which is just Grub)

enter image description here

I've run boot-repair and have the following log: http://paste2.org/tncfpPUJ

Here is the output from os-prober:

/dev/sda2@/EFI/Microsoft/Boot/bootmgfw.efi:Windows Boot Manager:Windows:efi

My ideal resolution for this is either have GRUB or reFind but either way be able to boot into Linux and Windows without having to go through this merry dance

0

In the end I tried several things suggested with both Linux and Windows install media but none worked. I had to go down the drastic route for re-installing Windows from scratch, the Mint.

Works as expected now.

  • what did you do that corrected the mint install? – Altoban Jan 10 '18 at 13:06
  • A completely fresh install – Tane Piper Jan 11 '18 at 14:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.