8

I am Vietnamese, I use ibus to type Vietnamese on my Debian. I just started to learn Hungarian and I need to type some Hungarian characters which I can't type with ibus-unikey, like ë, ö, ő, ü or ű.

Other characters like á, ó,... I can type with no problems as we have them in Vietnamese as well.

I added Hungarian to my ibus but I still can't figure out how to type those characters.

If you know how or if you know there are instructions somewhere, please let me know. I really appreciate. Thanks!

1 Answer 1

2

You can configure and use the composeKey:

Under gnome Desktop :

From the system settings choose keyboard >> keyboard layouts >> option then Select position of compose key extend it and choose (eg: Caps Lock)

enter image description here

To get the accented character press :

[composeKey] + [accent character] + [letter]

e,g:

Caps Lock + " + o = ö

Caps Lock + " + u = ü

Caps Lock + " + e = ë

Caps Lock + " + i = ï

Caps Lock + ~ + a = ã

edit:

Caps Lock + " + Shift + o = Ö

Under Kde Desktop

system settings >> imput devices >> keyboard >> Advanced >> configure keyboard option >> compose key position extend it then make your choice.

4
  • 1
    Thank you it works! I have a small question. If I press [Compose] + ["] + [o] I will get ó. [Compose] + [Shift] + ["] + [o] I will get Ö. How do I get the lowercase of Ö ?
    – Hung Tran
    Sep 22, 2016 at 3:04
  • @HungTran i edit my answer
    – GAD3R
    Sep 22, 2016 at 20:23
  • 1
    As a sidenote, you'll need [compose] + [=] + [o] → ő
    – grin
    Nov 3, 2016 at 7:48
  • @HungTran Re the lowercase of Ö — the pre-defined key sequences are in /usr/share/X11/locale/compose/*/Compose
    – gboffi
    Apr 23, 2020 at 15:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.