1

Here's my system info from uname -a:

Linux fu457 4.6.0-kali1-amd64 #1 SMP Debian 4.6.4-1kali1 (2016-07-21) x86_64 GNU/Linux

GNOME Shell 3.21.91

Now, when I go to 'Settings' and click on 'Keyboard' to add a custom shortcut key, the 'Keyboard' setting window will not open. It will flash a second or two in the taskbar (topbar) and exit immediately.

1

It seems the current work around for this is to upgrade to libgtk-3.0 from debian unstable. According to the bug tracker this should be added to the repos on 9/16. Although I just did a dist-upgrade and the problem still persists.

Here is the bug tracker https://bugs.kali.org/view.php?id=3579

  • Thanks. Does the upgrade to libgtk-3.0 from debian unstable work? I'm gonna try that now. – J04c Fu457 Sep 17 '16 at 21:54
  • Well, I tried it out and it seems to let you adjust keyboard shortcuts, but a lot of the other functionality is now missing. It's an improvement. – Harbinger Sep 19 '16 at 5:13
  • apt search libgtk-3.0 Sorting... Done Full Text Search... Done libgtk-3-0/kali-rolling,now 3.21.5-3 amd64 [installed] GTK+ graphical user interface library libgtk-3-0-dbg/kali-rolling,now 3.21.5-3 amd64 [installed] GTK+ libraries and debugging symbols I have the above packages and versions installed. Not sure if it's the right one but it doesn't seem to fix the issue for me. Any other options I can try? Or did I install the wrong packages? – J04c Fu457 Sep 19 '16 at 17:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.