2

I had Mate to configure my dual screen setup with mate-display-properties, but now I'm using nvidia-settings for configuring it.

The new configuration seems to work, on login (lightdm) and on Awesome the configuration made with nvidia-settings loads fine.

On Mate instead the mate-display-properties application is overriding nvidia-settings, I verified this by deactivating the Mate Settings Daemon and the Mate display configuration wasn't loaded but also the rest of the settings that I need.

How to reset or remove the old settings made with mate-display-properties to prevent Mate to override nvidia-settings?

1 Answer 1

2

While posting and testing I found a workaround but still, if someone knows how to remove mate-display-properties configuration would be better.

Anyway for sharing:

  1. Login into Mate
  2. Once logged launch nvidia-settings
  3. Configure the displays and Apply
  4. Now launch mate-display-properties and you'll see that now is set to the same configuration of nvidia-settings.
  5. Don't touch anything and click Apply.
  6. Now the override made by mate-display-properties takes still place but with the same configuration of nvidia-settings so is invisible to the user.
1
  • 1
    I think I'm a bit late but I also recently had this issue. I removed ~/.config/monitors.xml and that appears to have disabled the overriding config Apr 27, 2022 at 16:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .